summary refs log tree commit diff
path: root/gnu/packages/benchmark.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-06-08 14:46:24 +0200
committerLudovic Courtès <ludo@gnu.org>2022-06-08 14:46:24 +0200
commit8c3e9da13a3c92a7db308db8c0d81cb474ad7799 (patch)
tree88d06952aa5cc3a9c4991d9c43eb7950ff174fe1 /gnu/packages/benchmark.scm
parent5439c04ebdb7b6405f5ea2446b375f1d155a8d95 (diff)
parent0c5299200ffcd16370f047b7ccb187c60f30da34 (diff)
downloadguix-8c3e9da13a3c92a7db308db8c0d81cb474ad7799.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/benchmark.scm')
-rw-r--r--gnu/packages/benchmark.scm91
1 files changed, 53 insertions, 38 deletions
diff --git a/gnu/packages/benchmark.scm b/gnu/packages/benchmark.scm
index ce137d845e..b167c6de6e 100644
--- a/gnu/packages/benchmark.scm
+++ b/gnu/packages/benchmark.scm
@@ -1,7 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2016, 2017, 2021 Marius Bakke <marius@gnu.org>
 ;;; Copyright © 2017 Dave Love <fx@gnu.org>
-;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018–2022 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2019 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2019 Gábor Boskovits <boskovits@gmail.com>
@@ -63,46 +63,47 @@
 (define-public fio
   (package
     (name "fio")
-    (version "3.29")
+    (version "3.30")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://brick.kernel.dk/snaps/"
                                   "fio-" version ".tar.bz2"))
               (sha256
                (base32
-                "11k7ksksnb8lcbz0qdc9g7zlzaa0515j7kx4mlhk75sfs43v9zxc"))))
+                "1qjivkisn7dxk8irrb0rglmmdpbnai6n7vindf18ln0j24cc1x56"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:modules (,@%gnu-build-system-modules
-                  (ice-9 textual-ports))
-       #:test-target "test"
-       #:configure-flags '("--disable-native") ;don't generate code for the build CPU
-       #:phases
-       (modify-phases %standard-phases
-         (replace 'configure
-           (lambda* (#:key (configure-flags ''()) outputs #:allow-other-keys)
-             ;; The configure script doesn't understand some of the
-             ;; GNU options, so we can't use the stock phase.
-             (let ((out (assoc-ref outputs "out")))
-               (apply invoke "./configure"
-                      (string-append "--prefix=" out)
-                      configure-flags))))
-         ;; The main `fio` executable is fairly small and self contained.
-         ;; Moving the auxiliary scripts to a separate output saves ~100 MiB
-         ;; on the closure.
-         (add-after 'install 'move-outputs
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let ((oldbin (string-append (assoc-ref outputs "out") "/bin"))
-                   (newbin (string-append (assoc-ref outputs "utils") "/bin"))
-                   (script? (lambda* (file #:rest _)
-                              (call-with-input-file file
-                                (lambda (port)
-                                  (char=? #\# (peek-char port)))))))
-               (mkdir-p newbin)
-               (for-each (lambda (file)
-                           (link file (string-append newbin "/" (basename file)))
-                           (delete-file file))
-                         (find-files oldbin script?))))))))
+     (list #:modules
+           `(,@%gnu-build-system-modules
+             (ice-9 textual-ports))
+           #:test-target "test"
+           #:configure-flags
+           #~(list "--disable-native")  ;don't generate code for the build CPU
+           #:phases
+           #~(modify-phases %standard-phases
+               (replace 'configure
+                 (lambda* (#:key (configure-flags ''()) #:allow-other-keys)
+                   ;; The configure script doesn't understand some of the
+                   ;; GNU options, so we can't use the stock phase.
+                   (apply invoke "./configure"
+                          (string-append "--prefix=" #$output)
+                          configure-flags)))
+               ;; The main `fio` executable is fairly small and self contained.
+               ;; Moving the auxiliary scripts to a separate output saves ~100 MiB
+               ;; on the closure.
+               (add-after 'install 'move-outputs
+                 (lambda _
+                   (let ((oldbin (string-append #$output "/bin"))
+                         (newbin (string-append #$output:utils "/bin"))
+                         (script? (lambda* (file #:rest _)
+                                    (call-with-input-file file
+                                      (lambda (port)
+                                        (char=? #\# (peek-char port)))))))
+                     (mkdir-p newbin)
+                     (for-each (lambda (file)
+                                 (link file (string-append newbin "/" (basename file)))
+                                 (delete-file file))
+                               (find-files oldbin script?))))))))
     (outputs '("out" "utils"))
     (inputs
      (list libaio python zlib))
@@ -265,18 +266,25 @@ file metadata operations that can be performed per second.")
 (define-public python-locust
   (package
     (name "python-locust")
-    (version "2.5.1")
+    (version "2.8.6")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "locust" version))
        (sha256
         (base32
-         "1516z6z5pikybg7pma2cgxgj3wxaaky7z6d30mxf81wd4krbq16s"))))
+         "1gn13j758j36knlcdyyyggn60rpw98iqdkvl3kjsz34brysic6q1"))))
     (build-system python-build-system)
     (arguments
      '(#:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'relax-requirements
+           (lambda _
+             (substitute* "setup.py"
+               (("setuptools_scm<=6.0.1")
+                "setuptools_scm")
+               (("Jinja2<3.1.0")
+                "Jinja2"))))
          (replace 'check
            (lambda* (#:key tests? #:allow-other-keys)
              (when tests?
@@ -298,7 +306,10 @@ file metadata operations that can be performed per second.")
                                ;; respectively (see:
                                ;; https://github.com/locustio/locust/issues/1708).
                                "not test_custom_exit_code"
-                               "not test_webserver") " and "))))))))
+                               "not test_webserver"
+                               ;; This test fails with "AssertionError:
+                               ;; 'stopped' != 'stopping'".
+                               "not test_distributed_shape") " and "))))))))
     (propagated-inputs
      (list python-configargparse
            python-flask
@@ -306,6 +317,7 @@ file metadata operations that can be performed per second.")
            python-flask-cors
            python-gevent
            python-geventhttpclient
+           python-jinja2
            python-msgpack
            python-psutil
            python-pyzmq
@@ -314,8 +326,11 @@ file metadata operations that can be performed per second.")
            python-typing-extensions
            python-werkzeug))
     (native-inputs
-     (list python-mock python-pyquery python-pytest
-           python-retry python-setuptools-scm))
+     (list python-mock
+           python-pyquery
+           python-pytest
+           python-retry
+           python-setuptools-scm))
     (home-page "https://locust.io/")
     (synopsis "Distributed load testing framework")
     (description "Locust is a performance testing tool that aims to be easy to