summary refs log tree commit diff
path: root/gnu/packages/bioconductor.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-28 18:22:24 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-28 18:23:23 +0100
commit0ec0a5ecc973d4f33260e00fa5448cc54a7c3a20 (patch)
treeb0dc503f575e8710a2135f519fc57f7ceb118c74 /gnu/packages/bioconductor.scm
parenta793e88c5ed84f78fded2051649c06e1ac9a3efc (diff)
downloadguix-0ec0a5ecc973d4f33260e00fa5448cc54a7c3a20.tar.gz
gnu: Add r-a4core.
* gnu/packages/bioconductor.scm (r-a4core): New variable.
Diffstat (limited to 'gnu/packages/bioconductor.scm')
-rw-r--r--gnu/packages/bioconductor.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 4cc9887d33..4dffe978e9 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2959,3 +2959,26 @@ It allows searching of biological metadata using various criteria.")
     ;; Any version of the LGPL according to the DESCRIPTION file.  A copy of
     ;; the LGPL 2.1 is included.
     (license license:lgpl2.1+)))
+
+(define-public r-a4core
+  (package
+    (name "r-a4core")
+    (version "1.30.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "a4Core" version))
+       (sha256
+        (base32
+         "1d62afxkfp9zbp59ijcn4wd1gdynygw013av41wq8bfm3cx6f9zr"))))
+    (properties `((upstream-name . "a4Core")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-biobase" ,r-biobase)
+       ("r-glmnet" ,r-glmnet)))
+    (home-page "https://bioconductor.org/packages/a4Core")
+    (synopsis "Automated Affymetrix array analysis core package")
+    (description
+     "This is the core package for the automated analysis of Affymetrix
+arrays.")
+    (license license:gpl3)))