summary refs log tree commit diff
path: root/gnu/packages/bioconductor.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-09-07 12:01:03 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-09-07 12:01:03 +0200
commita59aee133068b96d6b65a7b7d60a8f84f0265c12 (patch)
tree0449eb5150545b8808acef686e77a1b92a1e55a8 /gnu/packages/bioconductor.scm
parent26da032d5b768811aefdbc979fd6b62472a8172d (diff)
downloadguix-a59aee133068b96d6b65a7b7d60a8f84f0265c12.tar.gz
gnu: Add r-bgeedb.
* gnu/packages/bioconductor.scm (r-bgeedb): New variable.
Diffstat (limited to 'gnu/packages/bioconductor.scm')
-rw-r--r--gnu/packages/bioconductor.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 68f6e8d773..7fb0a7520e 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -13827,6 +13827,40 @@ intergenic sequences.  These sequences are generated based on expression of
 all RNA-Seq libraries of each species integrated in Bgee.")
     (license license:gpl3)))
 
+(define-public r-bgeedb
+  (package
+    (name "r-bgeedb")
+    (version "2.18.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "BgeeDB" version))
+       (sha256
+        (base32
+         "1ziq180yfpdqwhjdzkwjjhwzn3kb0gkj6q0a26c7a30mcfb50w11"))))
+    (properties `((upstream-name . "BgeeDB")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-biobase" ,r-biobase)
+       ("r-curl" ,r-curl)
+       ("r-data-table" ,r-data-table)
+       ("r-digest" ,r-digest)
+       ("r-dplyr" ,r-dplyr)
+       ("r-graph" ,r-graph)
+       ("r-r-utils" ,r-r-utils)
+       ("r-rcurl" ,r-rcurl)
+       ("r-rsqlite" ,r-rsqlite)
+       ("r-tidyr" ,r-tidyr)
+       ("r-topgo" ,r-topgo)))
+    (native-inputs `(("r-knitr" ,r-knitr)))
+    (home-page "https://github.com/BgeeDB/BgeeDB_R")
+    (synopsis "Annotation and gene expression data retrieval from Bgee database")
+    (description
+     "This package provides a package for the annotation and gene expression
+data download from Bgee database, and TopAnat analysis: GO-like enrichment of
+anatomical terms, mapped to genes by expression patterns.")
+    (license license:gpl3)))
+
 (define-public r-tximeta
   (package
     (name "r-tximeta")