summary refs log tree commit diff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-10-06 14:10:18 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-10-08 09:13:55 +0200
commit26488f63b8e4845cc9ed6e91b0643936b5eaa509 (patch)
treecb1c599f2daf2c64914c700a408dc0756335d6de /gnu/packages/bioinformatics.scm
parent07f2e4993b5b80008273de0bb756659321e74183 (diff)
downloadguix-26488f63b8e4845cc9ed6e91b0643936b5eaa509.tar.gz
gnu: pigx-rnaseq: Remove dependency on pandoc-citeproc.
* gnu/packages/patches/pigx-rnaseq-no-citeproc.patch: Add patch.
* gnu/local.mk: Register it.
* gnu/packages/bioinformatics.scm (pigx-rnaseq)[source]: Use it.
[native-inputs]: Add automake/autoconf.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 150bbc361f..f5de16877e 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -10489,7 +10489,8 @@ once.  This package provides tools to perform Drop-seq analyses.")
                                   "/pigx_rnaseq-" version ".tar.gz"))
               (sha256
                (base32
-                "1ja3bda1appxrzbfy7wp7khy30mm7lic8xbq3gkbpc5bld3as9cm"))))
+                "1ja3bda1appxrzbfy7wp7khy30mm7lic8xbq3gkbpc5bld3as9cm"))
+              (patches (search-patches "pigx-rnaseq-no-citeproc.patch"))))
     (build-system gnu-build-system)
     (arguments
      `(#:parallel-tests? #f             ; not supported
@@ -10502,6 +10503,9 @@ once.  This package provides tools to perform Drop-seq analyses.")
              (substitute* "Makefile.in"
                (("^  tests/test_multiqc/test.sh") "")
                (("^  test.sh") ""))))
+         (add-before 'bootstrap 'autoreconf
+           (lambda _
+             (invoke "autoreconf" "-vif")))
          (add-before 'check 'set-timezone
            ;; The readr package is picky about timezones.
            (lambda* (#:key inputs #:allow-other-keys)
@@ -10545,7 +10549,9 @@ once.  This package provides tools to perform Drop-seq analyses.")
        ("python-deeptools" ,python-deeptools)
        ("python-pyyaml" ,python-pyyaml)))
     (native-inputs
-     `(("tzdata" ,tzdata)))
+     `(("tzdata" ,tzdata)
+       ("automake" ,automake)
+       ("autoconf" ,autoconf)))
     (home-page "https://bioinformatics.mdc-berlin.de/pigx/")
     (synopsis "Analysis pipeline for RNA sequencing experiments")
     (description "PiGX RNAseq is an analysis pipeline for preprocessing and