summary refs log tree commit diff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-09-19 22:11:45 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-09-20 09:53:52 +0300
commit7a2ee8524ab83fd3f22deda388f2fd0628cd7271 (patch)
treed5c8e9768295db73ce3debeb1778d0dc0ac84046 /gnu/packages/bioinformatics.scm
parent4b3b2e63007acee9e3a8c2ea728190480d092c3c (diff)
downloadguix-7a2ee8524ab83fd3f22deda388f2fd0628cd7271.tar.gz
gnu: wfmash: Update to 0.10.5.
* gnu/packages/bioinformatics.scm (wfmash): Update to 0.10.5.
[source]: Update to changes in source code.
[arguments]: Add configure-flag to enable more features.
[native-inputs]: Add pkg-config.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm15
1 files changed, 7 insertions, 8 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index b909cd5ee0..6acf37b312 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -20463,7 +20463,7 @@ based on the pairwise alignment of hidden Markov models (HMMs).")
 (define-public wfmash
   (package
     (name "wfmash")
-    (version "0.8.1")
+    (version "0.10.5")
     (source
      (origin
        (method url-fetch)
@@ -20471,7 +20471,7 @@ based on the pairwise alignment of hidden Markov models (HMMs).")
                            version "/wfmash-v" version ".tar.gz"))
        (sha256
         (base32
-         "031cm1arpfckvihb28vlk69mirpnmlag81zcscfba1bac58wvr7c"))
+         "1jsvnnh14h3ir4l13qhmglhd25kzwvni9apgvr1lbikqwgrpkiq4"))
        (snippet
         #~(begin
             (use-modules (guix build utils))
@@ -20482,14 +20482,12 @@ based on the pairwise alignment of hidden Markov models (HMMs).")
                "<atomic_queue/atomic_queue.h>"))
             ;; Remove compiler optimizations.
             (substitute* (find-files "." "CMakeLists\\.txt")
-              (("-mcx16 ") "")
-              (("-march=native ") ""))
-            ;; Allow building on architectures other than x86_64.
-            (substitute* "src/common/dset64.hpp"
-              (("!__x86_64__") "0"))))))
+              (("-march=native ") ""))))))
     (build-system cmake-build-system)
     (arguments
      (list
+       #:configure-flags
+       #~(list "-DWFA_PNG_AND_TSV=ON")
        #:phases
        #~(modify-phases %standard-phases
            (replace 'check
@@ -20602,7 +20600,8 @@ based on the pairwise alignment of hidden Markov models (HMMs).")
            jemalloc
            zlib))
     (native-inputs
-     (list samtools))
+     (list pkg-config
+           samtools))
     (synopsis "Base-accurate DNA sequence aligner")
     (description "@code{wfmash} is a DNA sequence read mapper based on mash
 distances and the wavefront alignment algorithm.  It is a fork of MashMap that