summary refs log tree commit diff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorNavid Afkhami <navid.afkhami@mdc-berlin.de>2023-08-18 14:01:06 +0000
committerRicardo Wurmus <rekado@elephly.net>2023-08-28 09:50:08 +0200
commitdd14ee0676cdd2ef9c5c0e8bfff66391c1975bd8 (patch)
treed472605a3a87c6ce7c590de260d88d6885f3d748 /gnu/packages/bioinformatics.scm
parent0aa74bebe31907c4abc71468319b220f908edd90 (diff)
downloadguix-dd14ee0676cdd2ef9c5c0e8bfff66391c1975bd8.tar.gz
gnu: Add python-scdamandtools.
* gnu/packages/bioinformatics.scm (python-scdamandtools): New variable.

Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 3e8fd887ee..2669942438 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2154,6 +2154,41 @@ Python.")
     ;; licensed lgpl2.1+
     (license (list license:expat license:lgpl2.1+))))
 
+(define-public python-scdamandtools
+  (package
+    (name "python-scdamandtools")
+    (version "1.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/KindLab/scDamAndTools")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1mblw6cn5jqik6ky8cv7ry99z6jm1i4r71pzdfl398vrwbda65gd"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list #:tests? #f))                ;there are none
+    (propagated-inputs (list python-h5py
+                             python-numpy
+                             python-sortedcontainers
+                             python-pandas
+                             python-pysam
+                             python-tqdm))
+    (native-inputs (list python-cython python-pytest))
+    (home-page "https://github.com/KindLab/scDamAndTools")
+    (synopsis "Functions for processing raw scDam&T-seq data")
+    (description
+     "This is a set of functions for processing raw scDam&T-seq data.
+scDam&T-seq is a method to simultaneously measure protein-DNA interactions and
+transcription from single cells (Rooijers et al., 2019).  It combines a
+DamID-based method to measure protein-DNA interactions and an adaptation of
+CEL-Seq to measure transcription.  The starting point of the workflow is raw
+sequencing data and the end result are tables of UMI-unique DamID and CEL-Seq
+counts.")
+    (license license:expat)))
+
 (define-public python-bioframe
   (package
     (name "python-bioframe")