summary refs log tree commit diff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-10-13 14:33:55 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 22:31:07 +0100
commitf2516de2fc7459d8ceed1779f0f24840075d08d6 (patch)
tree779150f1073b555f78e119a2bb92b3790a311265 /gnu/packages/bioinformatics.scm
parent328bb95d3507682f5e06fb2880c632252f59ee57 (diff)
downloadguix-f2516de2fc7459d8ceed1779f0f24840075d08d6.tar.gz
gnu: Fix python inputs, part 7: Ensure python-cython is a native-input.
* gnu/packages/audio.scm (python-pyliblo): [inputs] Move python-cyton to
  [native-inputs].
* gnu/packages/bioinformatics.scm (python2-pybedtools): dito.
* gnu/packages/music.scm (beast, python-pyportmidi): dito.
* gnu/packages/python.scm (python2-fastlmm, python-kivy): dito.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 9cfb30023f..9b47dc3d51 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -522,13 +522,13 @@ intended to behave exactly the same as the original BWK awk.")
     (build-system python-build-system)
     (arguments `(#:python ,python-2)) ; no Python 3 support
     (inputs
-     `(("python-cython" ,python2-cython)
-       ("python-matplotlib" ,python2-matplotlib)))
+     `(("python-matplotlib" ,python2-matplotlib)))
     (propagated-inputs
      `(("bedtools" ,bedtools)
        ("samtools" ,samtools)))
     (native-inputs
-     `(("python-pyyaml" ,python2-pyyaml)
+     `(("python-cython" ,python2-cython)
+       ("python-pyyaml" ,python2-pyyaml)
        ("python-nose" ,python2-nose)))
     (home-page "https://pythonhosted.org/pybedtools/")
     (synopsis "Python wrapper for BEDtools programs")