summary refs log tree commit diff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-06-02 13:29:52 +0200
committerLudovic Courtès <ludo@gnu.org>2016-06-05 00:05:38 +0200
commit698bd29799089c84bc2aa2c5f40e61eba83dd0b8 (patch)
tree1ab84a615f541fba557bacf842a77d7ef2650c5f /gnu/packages/bioinformatics.scm
parent1713c37f835a0566a47d76d2379b2d0b12c0b548 (diff)
downloadguix-698bd29799089c84bc2aa2c5f40e61eba83dd0b8.tar.gz
gnu: Use full SHA1 commit ids.
* gnu/packages/bioinformatics.scm (pbtranscript-tofu, mosaik,
  smithlab-cpp, piranha): Use full SHA1 commit ids.
* gnu/packages/ci.scm (hydra): Likewise.
* gnu/packages/compression.scm (sfarkxtc): Likewise.
* gnu/packages/emacs.scm (emacs-ob-ipython): Likewise.
* gnu/packages/games.scm (mars, emulation-station): Likewise.
* gnu/packages/gnunet.scm (guile-gnunet): Likewise.
* gnu/packages/music.scm (non-sequencer): Likewise.
* gnu/packages/version-control.scm (git-flow, git-test-sequence): Likewise.
* gnu/packages/xorg.scm (xf86-video-intel): Likewise.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 22bd81c75b..6a90aa9456 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2670,10 +2670,10 @@ the phenotype as it models the data.")
     (license license:asl2.0)))
 
 (define-public pbtranscript-tofu
-  (let ((commit "8f5467fe6"))
+  (let ((commit "8f5467fe6a4472bcfb4226c8720993c8507adfe4"))
     (package
       (name "pbtranscript-tofu")
-      (version (string-append "2.2.3." commit))
+      (version (string-append "2.2.3." (string-take commit 7)))
       (source (origin
                 (method git-fetch)
                 (uri (git-reference
@@ -3009,7 +3009,7 @@ viewer.")
                (delete 'configure))))))))
 
 (define-public mosaik
-  (let ((commit "5c25216d"))
+  (let ((commit "5c25216d3522d6a33e53875cd76a6d65001e4e67"))
     (package
       (name "mosaik")
       (version "2.2.30")
@@ -3259,10 +3259,10 @@ subsequent visualization, annotation and storage of results.")
 
 (define-public smithlab-cpp
   (let ((revision "1")
-        (commit "728a097"))
+        (commit "728a097bec88c6f4b8528b685932049e660eff2e"))
     (package
       (name "smithlab-cpp")
-      (version (string-append "0." revision "." commit))
+      (version (string-append "0." revision "." (string-take commit 7)))
       (source (origin
                 (method git-fetch)
                 (uri (git-reference
@@ -5169,7 +5169,7 @@ libraries for systems that do not have these available via other means.")
        ("samtools" ,samtools-0.1)
        ("gsl" ,gsl)
        ("smithlab-cpp"
-        ,(let ((commit "3723e2d"))
+        ,(let ((commit "3723e2db438c51501d0423429ff396c3035ba46a"))
            (origin
              (method git-fetch)
              (uri (git-reference