summary refs log tree commit diff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-06-18 12:17:53 +0100
committerChristopher Baines <mail@cbaines.net>2023-06-20 22:04:51 +0100
commit7b535eb29b9d52221f65bd3ca9d9ae53baad0cac (patch)
tree4b1218afcc46fc667e47c1eb0716945af2e1722b /gnu/packages/bioinformatics.scm
parent6bafbfd40ff9d1066ec4041b37f90cd34de5a099 (diff)
downloadguix-7b535eb29b9d52221f65bd3ca9d9ae53baad0cac.tar.gz
gnu: bioruby: Update to 2.0.4.
* gnu/packages/bioinformatics.scm (bioruby): Update to 2.0.4.
[arguments]: Update style.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm32
1 files changed, 16 insertions, 16 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 9e356cba5d..4edcc28d12 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -10876,34 +10876,34 @@ generate FASTA, JSON, YAML, RDF, JSON-LD, HTML, CSV, tabular output etc.")
 (define-public bioruby
   (package
     (name "bioruby")
-    (version "1.5.2")
+    (version "2.0.4")
     (source
      (origin
        (method url-fetch)
        (uri (rubygems-uri "bio" version))
        (sha256
         (base32
-         "1d56amdsjv1mag7m6gv2w0xij8hqx1v5xbdjsix8sp3yp36m7938"))))
+         "08aknxk2ingwscwfqpw5vnax6jpk1sxfaialravladb63hcl8dx9"))))
     (build-system ruby-build-system)
     (propagated-inputs
      (list ruby-libxml))
     (native-inputs
      (list which))  ; required for test phase
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-before 'build 'patch-test-command
-          (lambda _
-            (substitute* '("test/functional/bio/test_command.rb")
-              (("/bin/sh") (which "sh")))
-            (substitute* '("test/functional/bio/test_command.rb")
-              (("/bin/ls") (which "ls")))
-            (substitute* '("test/functional/bio/test_command.rb")
-              (("which") (which "which")))
-            (substitute* '("test/functional/bio/test_command.rb",
-                           "test/data/command/echoarg2.sh")
-              (("/bin/echo") (which "echo")))
-            #t)))))
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'build 'patch-test-command
+            (lambda _
+              (substitute* '("test/functional/bio/test_command.rb")
+                (("/bin/sh") (which "sh")))
+              (substitute* '("test/functional/bio/test_command.rb")
+                (("/bin/ls") (which "ls")))
+              (substitute* '("test/functional/bio/test_command.rb")
+                (("which") (which "which")))
+              (substitute* '("test/functional/bio/test_command.rb"
+                             "test/data/command/echoarg2.sh")
+                (("/bin/echo") (which "echo"))))))))
     (synopsis "Ruby library, shell and utilities for bioinformatics")
     (description "BioRuby comes with a comprehensive set of Ruby development
 tools and libraries for bioinformatics and molecular biology.  BioRuby has