summary refs log tree commit diff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2017-07-22 20:36:44 +1000
committerBen Woodcroft <donttrustben@gmail.com>2017-07-23 10:29:36 +1000
commit0620387a594be1e8069dea8cda83dfc4a0b7f2de (patch)
tree455f84f259e7c2759572ff078361c69857635256 /gnu/packages/bioinformatics.scm
parent63fa0ffcd43484c2d7dcf32866529c022309ff20 (diff)
downloadguix-0620387a594be1e8069dea8cda83dfc4a0b7f2de.tar.gz
gnu: bcftools: Update to 1.5.
* gnu/packages/bioinformatics.scm (bcftools): Update to 1.5.
[origin]: Remove fix-makefile patch.
[arguments]: Add configure flags, add LIBS make flag.  Do not delete
configure phase.
* gnu/packages/patches/bcftools-fix-makefile.patch: Remove file.
* gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 3e3aaeb657..d9f7e2a5e1 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -300,7 +300,7 @@ BAM files.")
 (define-public bcftools
   (package
     (name "bcftools")
-    (version "1.4.1")
+    (version "1.5")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -308,18 +308,19 @@ BAM files.")
                     version "/bcftools-" version ".tar.bz2"))
               (sha256
                (base32
-                "024xv59bzv148b6w3das4jmldf7rywsf8y1fbqznap008qc8gl6p"))
-              (patches (search-patches "bcftools-fix-makefile.patch"))
+                "0093hkkvxmbwfaa7905s6185jymynvg42kq6sxv7fili11l5mxwz"))
               (modules '((guix build utils)))
               (snippet
                ;; Delete bundled htslib.
-               '(delete-file-recursively "htslib-1.4.1"))))
+               '(delete-file-recursively "htslib-1.5"))))
     (build-system gnu-build-system)
     (arguments
      `(#:test-target "test"
+       #:configure-flags (list "--with-htslib=system")
        #:make-flags
        (list
         "USE_GPL=1"
+        "LIBS=-lgsl -lgslcblas"
         (string-append "prefix=" (assoc-ref %outputs "out"))
         (string-append "HTSDIR=" (assoc-ref %build-inputs "htslib") "/include")
         (string-append "HTSLIB=" (assoc-ref %build-inputs "htslib") "/lib/libhts.so")
@@ -328,7 +329,6 @@ BAM files.")
         (string-append "PACKAGE_VERSION=" ,version))
        #:phases
        (modify-phases %standard-phases
-         (delete 'configure)
          (add-before 'check 'patch-tests
            (lambda _
              (substitute* "test/test.pl"