summary refs log tree commit diff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-03-13 16:26:40 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2017-03-15 01:10:30 +0100
commitb2d748edff6d50d15e060c215c54eb8edbd45f08 (patch)
treeeed9022aafb1bc5495ebb3f38f451bc53bae9ad6 /gnu/packages/bioinformatics.scm
parent35dcfed370a3385fdd3743ddb64f2f0aaaee2fc6 (diff)
downloadguix-b2d748edff6d50d15e060c215c54eb8edbd45f08.tar.gz
gnu: samtools: End installation phases with truth.
* gnu/packages/bioinformatics.scm (samtools, samtools-0.1)[arguments]:
Return #T instead of the undefined results of COPY-FILE or INSTALL-FILE.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 770bea7e32..239b94b6c4 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4284,7 +4284,8 @@ to the user's query of interest.")
          'install 'install-library
          (lambda* (#:key outputs #:allow-other-keys)
            (let ((lib (string-append (assoc-ref outputs "out") "/lib")))
-             (install-file "libbam.a" lib)))
+             (install-file "libbam.a" lib)
+             #t))
          (alist-cons-after
           'install 'install-headers
           (lambda* (#:key outputs #:allow-other-keys)
@@ -4336,7 +4337,8 @@ viewer.")
                                (assoc-ref outputs "out") "/bin")))
                      (mkdir-p bin)
                      (copy-file "samtools"
-                                (string-append bin "/samtools")))))
+                                (string-append bin "/samtools"))
+                     #t)))
                (delete 'patch-tests)
                (delete 'configure))))))))