summary refs log tree commit diff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2020-12-23 19:06:32 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-12-29 17:40:28 +0100
commita2c66d18a565d85e94ea305429878d05e88b982a (patch)
treecbec65dbbad7a3d762e26564d4ce606c801f71c6 /gnu/packages/bioinformatics.scm
parent8c2b7c9a2ab9d11d5619e8314f26266cae672bd1 (diff)
downloadguix-a2c66d18a565d85e94ea305429878d05e88b982a.tar.gz
gnu: r-homo-sapiens: Move to (gnu packages bioconductor).
* gnu/packages/bioinformatics.scm (r-homo-sapiens): Move from here...
* gnu/packages/bioconductor.scm (r-homo-sapiens): ...to here.
Replace 'string-append' by 'bioconductor-uri' with 'annotation'.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm32
1 files changed, 0 insertions, 32 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 1c59d7a690..2a6ac38505 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -10623,38 +10623,6 @@ and more.")
 the earlier snpMatrix package, allowing for uncertainty in genotypes.")
     (license license:gpl3)))
 
-(define-public r-homo-sapiens
-  (package
-    (name "r-homo-sapiens")
-    (version "1.3.1")
-    (source (origin
-              (method url-fetch)
-              ;; We cannot use bioconductor-uri here because this tarball is
-              ;; located under "data/annotation/" instead of "bioc/".
-              (uri (string-append "https://www.bioconductor.org/packages/"
-                                  "release/data/annotation/src/contrib/"
-                                  "Homo.sapiens_"
-                                  version ".tar.gz"))
-              (sha256
-               (base32
-                "151vj7h5p1c8yd5swrchk46z469p135wk50hvkl0nhgndvy0jj01"))))
-    (properties
-     `((upstream-name . "Homo.sapiens")))
-    (build-system r-build-system)
-    (propagated-inputs
-     `(("r-genomicfeatures" ,r-genomicfeatures)
-       ("r-go-db" ,r-go-db)
-       ("r-org-hs-eg-db" ,r-org-hs-eg-db)
-       ("r-txdb-hsapiens-ucsc-hg19-knowngene" ,r-txdb-hsapiens-ucsc-hg19-knowngene)
-       ("r-organismdbi" ,r-organismdbi)
-       ("r-annotationdbi" ,r-annotationdbi)))
-    (home-page "https://bioconductor.org/packages/Homo.sapiens/")
-    (synopsis "Annotation package for the Homo.sapiens object")
-    (description
-     "This package contains the Homo.sapiens object to access data from
-several related annotation packages.")
-    (license license:artistic2.0)))
-
 (define-public r-dropbead
   (let ((commit "d746c6f3b32110428ea56d6a0001ce52a251c247")
         (revision "2"))