summary refs log tree commit diff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-01-27 22:13:19 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-01-27 22:15:25 +0100
commitf4cbf11c655475f0f0c21b0a69ca5bbb2e460133 (patch)
tree9d01697991440f89ca1e5b831f8861d5a0408136 /gnu/packages/bioinformatics.scm
parentf127bce3ecf4964d0733537b32266f93d816b6b5 (diff)
downloadguix-f4cbf11c655475f0f0c21b0a69ca5bbb2e460133.tar.gz
gnu: pigx-bsseq: Fix Python module capture.
The build system expects all Python modules to be on PYTHONPATH.

* gnu/packages/bioinformatics.scm (pigx-bsseq)[arguments]: Set PYTHONPATH
variable in new build phase.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 9e7191dad8..39f4a20051 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -11061,6 +11061,9 @@ in an easily configurable manner.")
          (add-before 'bootstrap 'autoreconf
            (lambda _
              (invoke "autoreconf" "-vif")))
+         (add-before 'configure 'set-PYTHONPATH
+           (lambda _
+             (setenv "PYTHONPATH" (getenv "GUIX_PYTHONPATH"))))
          (add-before 'check 'set-timezone
            ;; The readr package is picky about timezones.
            (lambda* (#:key inputs #:allow-other-keys)