summary refs log tree commit diff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-08-31 17:22:19 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-09-02 10:38:43 +0200
commit1921b1de0733eeb20c6255b04ac0c05325073ec8 (patch)
treee0249804ef45358ae572b27ad41f80c44cbcc74a /gnu/packages/bioinformatics.scm
parentf85ccf88efbe1250e472e95cce7130c8403d4f3c (diff)
downloadguix-1921b1de0733eeb20c6255b04ac0c05325073ec8.tar.gz
gnu: Add deeptools.
* gnu/packages/bioinformatics.scm (deeptools): New variable.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index d7e4da6fe8..03eb2dfe30 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -875,6 +875,45 @@ file formats including SAM/BAM, Wiggle/BigWig, BED, GFF/GTF, VCF.")
 other types of unwanted sequence from high-throughput sequencing reads.")
     (license license:expat)))
 
+(define-public deeptools
+  (package
+    (name "deeptools")
+    (version "1.5.11")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/fidelram/deepTools/archive/"
+                    version ".tar.gz"))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1kaagygcbvjs9sxd9cqmskd02wcfp9imvb735r087w7hwqpvz6fs"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:python ,python-2))
+    (propagated-inputs
+     `(("python-scipy" ,python2-scipy)
+       ("python-numpy" ,python2-numpy)
+       ("python-matplotlib" ,python2-matplotlib)
+       ("python-bx-python" ,python2-bx-python)
+       ("python-pysam" ,python2-pysam)))
+    (native-inputs
+     `(("python-mock" ,python2-mock) ;for tests
+       ("python-pytz" ,python2-pytz) ;for tests
+       ("python-setuptools" ,python2-setuptools)))
+    (home-page "https://github.com/fidelram/deepTools")
+    (synopsis "Tools for normalizing and visualizing deep-sequencing data")
+    (description
+     "DeepTools addresses the challenge of handling the large amounts of data
+that are now routinely generated from DNA sequencing centers.  To do so,
+deepTools contains useful modules to process the mapped reads data to create
+coverage files in standard bedGraph and bigWig file formats.  By doing so,
+deepTools allows the creation of normalized coverage files or the comparison
+between two files (for example, treatment and control).  Finally, using such
+normalized and standardized files, multiple visualizations can be created to
+identify enrichments with functional annotations of the genome.")
+    (license license:gpl3+)))
+
 (define-public diamond
   (package
     (name "diamond")