summary refs log tree commit diff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-10-06 14:11:15 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-10-08 09:13:55 +0200
commitc8a7ba621b99ee8e2e7cb0eb11637c446b5ec244 (patch)
tree5aa80e280ce756f9672d8852b1172531590d301e /gnu/packages/bioinformatics.scm
parent26488f63b8e4845cc9ed6e91b0643936b5eaa509 (diff)
downloadguix-c8a7ba621b99ee8e2e7cb0eb11637c446b5ec244.tar.gz
gnu: pigx-scrnaseq: Remove dependency on pandoc-citeproc.
* gnu/packages/patches/pigx-scrnaseq-no-citeproc.patch: Add patch.
* gnu/local.mk: Register it.
* gnu/packages/bioinformatics.scm (pigx-scrnaseq)[source]: Use it.
[native-inputs]: Add automake/autoconf.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index f5de16877e..082e47bf5b 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -10732,8 +10732,18 @@ methylation and segmentation.")
                                   "/pigx_scrnaseq-" version ".tar.gz"))
               (sha256
                (base32
-                "1h5mcxzwj3cidlkvy9ly5wmi48vwfsjf8dxjfirknqxr9a92hwlx"))))
+                "1h5mcxzwj3cidlkvy9ly5wmi48vwfsjf8dxjfirknqxr9a92hwlx"))
+              (patches (search-patches "pigx-scrnaseq-no-citeproc.patch"))))
     (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'bootstrap 'autoreconf
+           (lambda _
+             (invoke "autoreconf" "-vif"))))))
+    (native-inputs
+     `(("automake" ,automake)
+       ("autoconf" ,autoconf)))
     (inputs
      `(("coreutils" ,coreutils)
        ("perl" ,perl)