summary refs log tree commit diff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2017-08-03 20:37:25 +1000
committerBen Woodcroft <donttrustben@gmail.com>2017-08-03 21:02:30 +1000
commit92971d68ac942cd4a38092b4ccb20a8192a56aaf (patch)
treed551aed45228af4824c56b5ab6bc7b266254a53d /gnu/packages/bioinformatics.scm
parenta8ead6f91b74dbc5c776a5029a62e15bd84d7b0e (diff)
downloadguix-92971d68ac942cd4a38092b4ccb20a8192a56aaf.tar.gz
gnu: htseq: Update to 0.9.1.
* gnu/packages/bioinformatics.scm (htseq): Update to 0.9.1.
[arguments]: Use python-3 by removing field.
[native-inputs]: Add 'python-cython'.
[propagated-inputs]: Use python3 numpy package.
[inputs]: Use python3 pysam package.  Add 'python-matplotlib'.
(python2-htseq): New variable.
(clipper)[inputs]: Use it.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm17
1 files changed, 11 insertions, 6 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index b47d13ea55..4de245abe6 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1636,7 +1636,7 @@ databases.")
     (build-system python-build-system)
     (arguments `(#:python ,python-2)) ; only Python 2 is supported
     (inputs
-     `(("htseq" ,htseq)
+     `(("htseq" ,python2-htseq)
        ("python-pybedtools" ,python2-pybedtools)
        ("python-cython" ,python2-cython)
        ("python-scikit-learn" ,python2-scikit-learn)
@@ -2981,7 +2981,7 @@ HMMs).")
 (define-public htseq
   (package
     (name "htseq")
-    (version "0.6.1")
+    (version "0.9.1")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -2989,14 +2989,16 @@ HMMs).")
                     version ".tar.gz"))
               (sha256
                (base32
-                "1i85ppf2j2lj12m0x690qq5nn17xxk23pbbx2c83r8ayb5wngzwv"))))
+                "11flgb1381xdhk43bzbfm3vhnszkpqg6jk76rpa5xd1zbrvvlnxg"))))
     (build-system python-build-system)
-    (arguments `(#:python ,python-2)) ; only Python 2 is supported
+    (native-inputs
+     `(("python-cython" ,python-cython)))
     ;; Numpy needs to be propagated when htseq is used as a Python library.
     (propagated-inputs
-     `(("python-numpy" ,python2-numpy)))
+     `(("python-numpy" ,python-numpy)))
     (inputs
-     `(("python-pysam" ,python2-pysam)))
+     `(("python-pysam" ,python-pysam)
+       ("python-matplotlib" ,python-matplotlib)))
     (home-page "http://www-huber.embl.de/users/anders/HTSeq/")
     (synopsis "Analysing high-throughput sequencing data with Python")
     (description
@@ -3004,6 +3006,9 @@ HMMs).")
 from high-throughput sequencing assays.")
     (license license:gpl3+)))
 
+(define-public python2-htseq
+  (package-with-python2 htseq))
+
 (define-public java-htsjdk
   (package
     (name "java-htsjdk")