summary refs log tree commit diff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-07-29 22:44:37 +1000
committerBen Woodcroft <donttrustben@gmail.com>2018-07-29 22:53:10 +1000
commit9e0c135c39b5f1fa2c5c9cd4a1e50ccee75cc31e (patch)
tree5fa0a3d6f41d8354d017cbec60d00d1836c1a70c /gnu/packages/bioinformatics.scm
parent19601e895b816afc033a155a9309037ec21fd3ed (diff)
downloadguix-9e0c135c39b5f1fa2c5c9cd4a1e50ccee75cc31e.tar.gz
gnu: python-dendropy: Update to 4.4.0.
* gnu/packages/bioinformatics.scm (python-dendropy, python2-dendropy):
Update to 4.4.0.
[source]: Use GitHub URI. Remove patch.
[properties]: Remove field.
(python2-dendropy)[arguments]: Run tests with setup.py.
[native-inputs]: Remove 'python2-nose.
* gnu/packages/patches/python-dendropy-fix-tests.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Delete it.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm28
1 files changed, 9 insertions, 19 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 4d84b90f1e..7509f07d4a 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1971,15 +1971,18 @@ accessing bigWig files.")
 (define-public python-dendropy
   (package
     (name "python-dendropy")
-    (version "4.2.0")
+    (version "4.4.0")
     (source
      (origin
        (method url-fetch)
-       (uri (pypi-uri "DendroPy" version))
+       ;; Source from GitHub so that tests are included.
+       (uri
+        (string-append "https://github.com/jeetsukumaran/DendroPy/archive/v"
+                       version ".tar.gz"))
+       (file-name (string-append name "-" version ".tar.gz"))
        (sha256
         (base32
-         "15c7s3d5gf19ljsxvq5advaa752wfi7pwrdjyhzmg85hccyvp47p"))
-       (patches (search-patches "python-dendropy-fix-tests.patch"))))
+         "0v2fccny5xjaah546bsch1mw4kh61qq5frz2ibllxs9mp6ih9bsn"))))
     (build-system python-build-system)
     (home-page "http://packages.python.org/DendroPy/")
     (synopsis "Library for phylogenetics and phylogenetic computing")
@@ -1987,23 +1990,10 @@ accessing bigWig files.")
      "DendroPy is a library for phylogenetics and phylogenetic computing: reading,
 writing, simulation, processing and manipulation of phylogenetic
 trees (phylogenies) and characters.")
-    (license license:bsd-3)
-    (properties `((python2-variant . ,(delay python2-dendropy))))))
+    (license license:bsd-3)))
 
 (define-public python2-dendropy
-  (let ((base (package-with-python2 (strip-python2-variant python-dendropy))))
-    (package
-      (inherit base)
-      (arguments
-       `(#:python ,python-2
-         #:phases
-           (modify-phases %standard-phases
-             (replace 'check
-               ;; There is currently a test failure that only happens on some
-               ;; systems, and only using "setup.py test"
-               (lambda _ (zero? (system* "nosetests")))))))
-      (native-inputs `(("python2-nose" ,python2-nose)
-                       ,@(package-native-inputs base))))))
+  (package-with-python2 python-dendropy))
 
 (define-public python-py2bit
   (package