summary refs log tree commit diff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-05-12 22:21:14 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-05-12 22:21:14 +0200
commitfac8721bfd9516fec63c39c2bfe8ccbd3f6f0e1e (patch)
tree5aa62d09ff5c88730bf3de30d57fdfa919bb6da8 /gnu/packages/bioinformatics.scm
parent0e20ed322d5f0f2b8e50d31c7ec44b45be392e52 (diff)
downloadguix-fac8721bfd9516fec63c39c2bfe8ccbd3f6f0e1e.tar.gz
gnu: ribotaper: Simplify with G-expression.
* gnu/packages/bioinformatics.scm (ribotaper)[arguments]: Use G-expression and
drop trailing #T from build phase.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm27
1 files changed, 13 insertions, 14 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index d1de973274..b3576159ed 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1152,20 +1152,19 @@ cpp.find_library('hdf5_cpp', dirs : '~a'), "
                 "0ykjbps1y3z3085q94npw8i9x5gldc6shy8vlc08v76zljsm07hv"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'install 'wrap-executables
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out")))
-               (for-each
-                (lambda (script)
-                  (wrap-program (string-append out "/bin/" script)
-                    `("R_LIBS_SITE" ":" = (,(getenv "R_LIBS_SITE")))))
-                '("create_annotations_files.bash"
-                  "create_metaplots.bash"
-                  "Ribotaper_ORF_find.sh"
-                  "Ribotaper.sh")))
-             #t)))))
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'install 'wrap-executables
+            (lambda _
+              (for-each
+               (lambda (script)
+                 (wrap-program (string-append #$output "/bin/" script)
+                   `("R_LIBS_SITE" ":" = (,(getenv "R_LIBS_SITE")))))
+               '("create_annotations_files.bash"
+                 "create_metaplots.bash"
+                 "Ribotaper_ORF_find.sh"
+                 "Ribotaper.sh")))))))
     (inputs
      (list bedtools-2.18
            samtools-0.1