summary refs log tree commit diff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-05-06 18:55:45 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-05-06 18:56:24 +0200
commitce7b202f9b157c173cb9c2ab8d7a4b2d4a17496a (patch)
tree3ce4da691348362b05c1469f4da6af6b07ba24ae /gnu/packages/bioinformatics.scm
parent317da145c9b2c810ac7b73458e3488c48506fa46 (diff)
downloadguix-ce7b202f9b157c173cb9c2ab8d7a4b2d4a17496a.tar.gz
gnu: Add perl-bio-db-hts.
* gnu/packages/bioinformatics.scm (perl-bio-db-hts): New variable.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index df317df411..60614613bd 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1154,6 +1154,31 @@ converted to Alignment objects, and so on.  This means that the objects
 provide a coordinated and extensible framework to do computational biology.")
       (license license:perl-license))))
 
+(define-public perl-bio-db-hts
+  (package
+    (name "perl-bio-db-hts")
+    (version "3.01")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/A/AV/AVULLO/Bio-DB-HTS-"
+                           version ".tar.gz"))
+       (sha256
+        (base32
+         "0hjg0igfkpvh27zdkdr6pa7cqm9n6r7cwz0np74cl4wmawgvr9hj"))))
+    (build-system perl-build-system)
+    (native-inputs
+     `(("perl-module-build" ,perl-module-build)
+       ("pkg-config" ,pkg-config)))
+    (propagated-inputs
+     `(("bioperl-minimal" ,bioperl-minimal)
+       ("htslib" ,htslib-1.9)))
+    (home-page "https://metacpan.org/release/Bio-DB-HTS")
+    (synopsis "Perl interface to HTS library for DNA sequencing")
+    (description "This is a Perl interface to the HTS library for DNA
+sequencing.")
+    (license license:asl2.0)))
+
 (define-public python-biopython
   (package
     (name "python-biopython")