summary refs log tree commit diff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-10-19 23:45:12 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 22:32:00 +0100
commit54c85e12fda033ef01bb2c649b540d9694a368f3 (patch)
tree51b2f9df5ceb110a90bc124ff44f4be6da4e1cf9 /gnu/packages/bioinformatics.scm
parent3221207417fa48d0b954520450980812932b804c (diff)
downloadguix-54c85e12fda033ef01bb2c649b540d9694a368f3.tar.gz
gnu: python2-warpedlmm: Remove phase remove-bin-directory.
This directory did contain contain wrappers for `nose`, which should not
be there anyway (since nose already was a native-input). The new
python build system no longer creates this directory, while the old one
did. (This difference is due to the bloody details of how packages are
installed.)

* gnu/packages/bioinformatics.scm (python2-warpedlmm)
  [modify-phases] Remove, since remove-bin-directory was the only
  modification here.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm13
1 files changed, 1 insertions, 12 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 9b47dc3d51..0d5d8ff32a 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3509,18 +3509,7 @@ files and writing bioinformatics applications.")
          "1agfz6zqa8nc6cw47yh0s3y14gkpa9wqazwcj7mwwj3ffnw39p3j"))))
     (build-system python-build-system)
     (arguments
-     `(#:python ,python-2  ; requires Python 2.7
-       #:phases
-       (modify-phases %standard-phases
-         (add-after
-          'install 'remove-bin-directory
-          (lambda* (#:key outputs #:allow-other-keys)
-            ;; The "bin" directory only contains wrappers for running
-            ;; the module tests.  They are not needed after the
-            ;; "check" phase.
-            (delete-file-recursively
-             (string-append (assoc-ref outputs "out") "/bin"))
-            #t)))))
+     `(#:python ,python-2))  ; requires Python 2.7
     (propagated-inputs
      `(("python-scipy" ,python2-scipy)
        ("python-numpy" ,python2-numpy)