summary refs log tree commit diff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-04-24 19:40:15 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-04-24 19:49:04 +0200
commitbca1496f7290a0ae9a0186f325f3806b6209e6c3 (patch)
tree07e0e4ec23b1650e10f8963c98a969a1816c2414 /gnu/packages/bioinformatics.scm
parent523e5ee2f1c29267f55839d273687e2fd20475d8 (diff)
downloadguix-bca1496f7290a0ae9a0186f325f3806b6209e6c3.tar.gz
gnu: multiqc: Update to 1.14.
* gnu/packages/bioinformatics.scm (multiqc): Update to 1.14.
[build-system]: Use pyproject-build-system.
[arguments]: Simplify check phase; restore sanity-check phase.
[propagated-inputs]: Add python-rich-click.
[native-inputs]: Update test data.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm22
1 files changed, 8 insertions, 14 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index d6b8dcaad4..042250e46b 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -10651,33 +10651,26 @@ replacement for strverscmp.")
 (define-public multiqc
   (package
     (name "multiqc")
-    (version "1.10.1")
+    (version "1.14")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "multiqc" version))
        (sha256
         (base32
-         "0y9sgjca3bp0kk3ngry4zf4q2diyzp5bvzsx5l23nsysfbfkigm4"))))
-    (build-system python-build-system)
+         "0qlk2h0765hxp1w9hqf925rh8hq642lzgs6ppg91wln9y02s9fyw"))))
+    (build-system pyproject-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
          (replace 'check
-           (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+           (lambda* (#:key inputs tests? #:allow-other-keys)
              (when tests?
                (setenv "HOME" "/tmp")
                (let ((here (getcwd)))
                  (copy-recursively (assoc-ref inputs "tests") "/tmp/tests")
-                 ;; ModuleNotFoundError: No module named 'multiqc.modules.ccs'
-                 (delete-file "/tmp/tests/unit_tests/test_ccs.py")
                  (with-directory-excursion "/tmp/tests"
-                   (setenv "GUIX_PYTHONPATH"
-                           (string-append here ":" (getenv "GUIX_PYTHONPATH")))
-                   (invoke "python" "-munittest" "discover"))))))
-         ;; TODO: importing the picard and gatk modules fails for unknown
-         ;; reasons.
-         (delete 'sanity-check))))
+                   (invoke "multiqc" "data" "--ignore" "data/modules")))))))))
     (propagated-inputs
      (list python-click
            python-coloredlogs
@@ -10691,12 +10684,13 @@ replacement for strverscmp.")
            python-pyyaml
            python-requests
            python-rich
+           python-rich-click
            python-simplejson
            python-spectra))
     (native-inputs
      `(("python-pytest" ,python-pytest)
        ("tests"
-        ,(let ((commit "02272d48a382beb27489fcf9e6308a0407dc3c2e"))
+        ,(let ((commit "c3e7400affe3f3ca996973805797af61b93070ba"))
            (origin
              (method git-fetch)
              (uri (git-reference
@@ -10705,7 +10699,7 @@ replacement for strverscmp.")
              (file-name (git-file-name "multiqc-test-data" commit))
              (sha256
               (base32
-               "1bha64wanrigczw4yn81din56396n61j5gqdrkslhslmskcafi91")))))))
+               "0wwqbkbfnqj5ax6l0da4csbmv1sw7ya7mwvdwryckaiqmkxy80va")))))))
     (home-page "https://multiqc.info")
     (synopsis "Aggregate bioinformatics analysis reports")
     (description