summary refs log tree commit diff
path: root/gnu/packages/bittorrent.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-05-26 08:59:22 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-05-26 08:59:41 +0300
commit5bed95efd496d7a13dcc6dbde517a11ce5a44870 (patch)
tree087cf09bf41f483ac3e7ee5cf39de69ee3273439 /gnu/packages/bittorrent.scm
parent1fd11c92592eb4e63d6044c7c840dcb69b9e65e6 (diff)
downloadguix-5bed95efd496d7a13dcc6dbde517a11ce5a44870.tar.gz
gnu: aria2: Update to 1.23.0.
* gnu/packages/bittorrent.scm (aria2): Update to 1.23.0.
[inputs]: Move cppunit ...
[native-inputs]: ... to here.
[home-page]: Update to new Github website.
Diffstat (limited to 'gnu/packages/bittorrent.scm')
-rw-r--r--gnu/packages/bittorrent.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index d8252c8b37..409731d1d6 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -207,7 +207,7 @@ interface, for the Transmission BitTorrent daemon.")
 (define-public aria2
   (package
     (name "aria2")
-    (version "1.22.0")
+    (version "1.23.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://github.com/tatsuhiro-t/aria2/"
@@ -215,7 +215,7 @@ interface, for the Transmission BitTorrent daemon.")
                                   name "-" version ".tar.xz"))
               (sha256
                (base32
-                "12agwdvvkr34wqhyyfp418dj0k7nbr297qmcd3wj5kkn7brv6gxc"))))
+                "14qz7686zxnhbaqj6l1hqpkykhpygm74h2mzwhh13gqmcj38alaq"))))
     (build-system gnu-build-system)
     (arguments
      `(#:configure-flags '("--enable-libaria2")
@@ -230,10 +230,10 @@ interface, for the Transmission BitTorrent daemon.")
                (("CPPUNIT_TEST_SUITE_REGISTRATION\\(LpdMessageReceiverTest\\);" text)
                 (string-append "// " text))))))))
     (native-inputs
-     `(("pkg-config" ,pkg-config)))
+     `(("cppunit" ,cppunit) ; for the tests
+       ("pkg-config" ,pkg-config)))
     (inputs
      `(("c-ares" ,c-ares)
-       ("cppunit" ,cppunit) ; for the tests
        ("gnutls" ,gnutls)
        ("gmp" ,gmp)
        ("libssh2" ,libssh2)
@@ -241,7 +241,7 @@ interface, for the Transmission BitTorrent daemon.")
        ("nettle" ,nettle)
        ("sqlite" ,sqlite)
        ("zlib" ,zlib)))
-    (home-page "http://aria2.sourceforge.net/")
+    (home-page "https://aria2.github.io/")
     (synopsis "Utility for parallel downloading files")
     (description
       "Aria2 is a lightweight, multi-protocol & multi-source command-line