summary refs log tree commit diff
path: root/gnu/packages/bittorrent.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-01-19 11:28:21 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-01-19 13:04:21 +0200
commitd6255062954c67bb73aa342fffc070e0955a336f (patch)
tree08c467260c8ced8c8bfc2e0bb55f2cf1f9f943e1 /gnu/packages/bittorrent.scm
parent83d331437f26bcb546b2200959d69d209a88d1e6 (diff)
downloadguix-d6255062954c67bb73aa342fffc070e0955a336f.tar.gz
gnu: libtorrent-rasterbar: Update to 1.2.15.
* gnu/packages/bittorrent.scm (libtorrent-rasterbar): Update to 1.2.15.
[arguments]: Add phase to adjust test timeout. Adjust custom 'check
phase to update faketime date and output debug information on test
failures.
Diffstat (limited to 'gnu/packages/bittorrent.scm')
-rw-r--r--gnu/packages/bittorrent.scm15
1 files changed, 11 insertions, 4 deletions
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index 59ae6ac2f2..8242819228 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -422,7 +422,7 @@ and will take advantage of multiple processor cores where possible.")
 (define-public libtorrent-rasterbar
   (package
     (name "libtorrent-rasterbar")
-    (version "1.2.14")
+    (version "1.2.15")
     (source
      (origin
        (method url-fetch)
@@ -431,13 +431,18 @@ and will take advantage of multiple processor cores where possible.")
                        "releases/download/v" version "/"
                        "libtorrent-rasterbar-" version ".tar.gz"))
        (sha256
-        (base32 "0gwm4w7337ykh5lfnspapnnz6a35g7yay3wnj126s8s5kcsvy9wy"))))
+        (base32 "0jr1c876mvwbbbnav8ldcdm1l6z3g404jc5wp8z902jcd0w8dbf8"))))
     (build-system cmake-build-system)
     (arguments
      `(#:configure-flags '("-Dpython-bindings=ON"
                            "-Dbuild_tests=ON")
        #:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'extend-test-timeout
+           (lambda _
+             (substitute* "test/test_remove_torrent.cpp"
+               ;; Extend the test timeout from 3 seconds to 10.
+               (("i > 30") "i > 100"))))
          (replace 'check
            (lambda* (#:key tests? parallel-tests? #:allow-other-keys)
              (let ((disabled-tests
@@ -448,12 +453,14 @@ and will take advantage of multiple processor cores where possible.")
                  ;; expiry date.  To ensure succesful builds in the future,
                  ;; fake the time to be roughly that of the release.
                  (setenv "FAKETIME_ONLY_CMDS" "test_ssl")
-                 (invoke "faketime" "2021-06-01"
+                 (invoke "faketime" "2021-12-12"
                          "ctest"
                          "--exclude-regex" (string-join disabled-tests "|")
                          "-j" (if parallel-tests?
                                   (number->string (parallel-job-count))
-                                  "1")))))))))
+                                  "1")
+                         "--rerun-failed"
+                         "--output-on-failure"))))))))
     (inputs (list boost openssl))
     (native-inputs `(("libfaketime" ,libfaketime)
                      ("python" ,python-wrapper)