summary refs log tree commit diff
path: root/gnu/packages/boost.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-05-24 15:10:55 -0400
committerMark H Weaver <mhw@netris.org>2018-05-25 14:07:28 -0400
commit0ff4e49a95d8a54cd5508f441b927a670d348519 (patch)
treed43010e904e8af729dad3d5971ec0ac999a4a163 /gnu/packages/boost.scm
parent9d10a63402e3c3dcda288b9370d04568dfa20ea6 (diff)
downloadguix-0ff4e49a95d8a54cd5508f441b927a670d348519.tar.gz
gnu: boost: Re-enable context and coroutine libraries on MIPS.
* gnu/packages/boost.scm (boost)[arguments]: Remove the extra make-flags
"--without-context", "--without-coroutine", and "--without-coroutine2" that
were previously added on mips64 systems.
Diffstat (limited to 'gnu/packages/boost.scm')
-rw-r--r--gnu/packages/boost.scm11
1 files changed, 1 insertions, 10 deletions
diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index d8ce30cd88..d00f96de64 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -68,16 +68,7 @@
 
              ;; Set the RUNPATH to $libdir so that the libs find each other.
              (string-append "linkflags=-Wl,-rpath="
-                            (assoc-ref %outputs "out") "/lib")
-
-             ;; Boost's 'context' library is not yet supported on mips64, so
-             ;; we disable it.  The 'coroutine' library depends on 'context',
-             ;; so we disable that too.
-             ,@(if (string-prefix? "mips64" (or (%current-target-system)
-                                                (%current-system)))
-                   '("--without-context"
-                     "--without-coroutine" "--without-coroutine2")
-                   '()))
+                            (assoc-ref %outputs "out") "/lib"))
        #:phases
        (modify-phases %standard-phases
          (delete 'bootstrap)