summary refs log tree commit diff
path: root/gnu/packages/boost.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-07-05 23:04:31 +0200
committerMarius Bakke <marius@gnu.org>2022-07-06 00:35:17 +0200
commit526071290f7329250adfdd6fa17de00ac84b1773 (patch)
treeb96cd1eb705d895ad40b3f4cb9ca417b2a5e9916 /gnu/packages/boost.scm
parentd1e9f626b4d6230fa41db920cf87af9281ffe5de (diff)
downloadguix-526071290f7329250adfdd6fa17de00ac84b1773.tar.gz
gnu: boost, boost-static: Consolidate libboost_python phases.
* gnu/packages/boost.scm (boost)[arguments]: Determine library extension based
on #:make-flags in 'provide-libboost_python phase.
(boost-static)[arguments]: Remove #:phases.
Diffstat (limited to 'gnu/packages/boost.scm')
-rw-r--r--gnu/packages/boost.scm34
1 files changed, 11 insertions, 23 deletions
diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index 89d3379d03..d6307d587a 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -173,23 +173,26 @@
           #$@(if (%current-target-system)
                  #~()
                  #~((add-after 'install 'provide-libboost_python
-                      (lambda* (#:key inputs outputs #:allow-other-keys)
-                        (let* ((python-version (python-version
+                      (lambda* (#:key make-flags inputs outputs #:allow-other-keys)
+                        (let* ((static? (member "link=static" make-flags))
+                               (libext (if static? ".a" ".so"))
+                               (python-version (python-version
                                                 #+(this-package-native-input
                                                    "python-minimal-wrapper")))
-                               (libboost_pythonNN.so
+                               (libboost_pythonNN
                                 (string-append "libboost_python"
                                                (string-join (string-split
                                                              python-version #\.)
                                                             "")
-                                               ".so")))
+                                               libext)))
                           (with-directory-excursion (string-append #$output "/lib")
-                            (symlink libboost_pythonNN.so "libboost_python.so")
+                            (symlink libboost_pythonNN
+                                     (string-append "libboost_python" libext))
                             ;; Some packages only look for the major version.
-                            (symlink libboost_pythonNN.so
+                            (symlink libboost_pythonNN
                                      (string-append "libboost_python"
                                                     (string-take python-version 1)
-                                                    ".so")))))))))))
+                                                    libext)))))))))))
 
     (home-page "https://www.boost.org")
     (synopsis "Peer-reviewed portable C++ source libraries")
@@ -291,22 +294,7 @@ across a broad spectrum of applications.")
     (arguments
      (substitute-keyword-arguments (package-arguments boost)
        ((#:make-flags flags)
-        #~(cons "link=static" (delete "link=shared" #$flags)))
-       ((#:phases phases)
-        #~(modify-phases #$phases
-            (replace 'provide-libboost_python
-              (lambda* (#:key inputs outputs #:allow-other-keys)
-                (let* ((python-version (python-version
-                                        #+(this-package-native-input
-                                           "python-minimal-wrapper")))
-                       (libboost_pythonNN.a
-                        (string-append "libboost_python"
-                                       (string-join (string-split
-                                                     python-version #\.)
-                                                    "")
-                                       ".a")))
-                  (with-directory-excursion (string-append #$output "/lib")
-                    (symlink libboost_pythonNN.a "libboost_python.a")))))))))))
+        #~(cons "link=static" (delete "link=shared" #$flags)))))))
 
 (define-public boost-for-mysql
   ;; Older version for MySQL 5.7.23.