summary refs log tree commit diff
path: root/gnu/packages/boost.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-08-22 20:03:29 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-08-23 14:56:02 +0200
commitbd65ecf4608152d586be610add0c9d2ab2b4ac25 (patch)
tree9f00e9741c87cf3350a360d9cfe198a0429e1df3 /gnu/packages/boost.scm
parent22cf2f4abfa2b1ad5620d35644b6538b7041dbf1 (diff)
downloadguix-bd65ecf4608152d586be610add0c9d2ab2b4ac25.tar.gz
gnu: boost: Provide libboost_python compatibility symlink.
* gnu/packages/boost.scm (boost)[arguments]: Add phase 'provide-libboost_python'.
Diffstat (limited to 'gnu/packages/boost.scm')
-rw-r--r--gnu/packages/boost.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index fbd0425c96..71b34ada1f 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -100,7 +100,18 @@
                     make-flags)))
          (replace 'install
            (lambda* (#:key make-flags #:allow-other-keys)
-             (apply invoke "./b2" "install" make-flags))))))
+             (apply invoke "./b2" "install" make-flags)))
+         (add-after 'install 'provide-libboost_python
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out")))
+               ;; Boost can build support for both Python 2 and Python 3 since
+               ;; version 1.67.0, and suffixes each library with the Python
+               ;; version.  Many consumers only check for libboost_python
+               ;; however, so we provide it here as suggested in
+               ;; <https://github.com/boostorg/python/issues/203>.
+               (with-directory-excursion (string-append out "/lib")
+                 (symlink "libboost_python27.so" "libboost_python.so"))
+               #t))))))
 
     (home-page "https://www.boost.org")
     (synopsis "Peer-reviewed portable C++ source libraries")