summary refs log tree commit diff
path: root/gnu/packages/boost.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-05-01 06:50:34 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-05-01 06:51:15 +0200
commita2cfe190411724eaf0c38777018367724c9007a5 (patch)
tree4b634d6f83bbf19ec59412e3789e5a416a0bc72c /gnu/packages/boost.scm
parent9eecf9bc13bd3746ce5a073c59920110c6cf3dd7 (diff)
downloadguix-a2cfe190411724eaf0c38777018367724c9007a5.tar.gz
gnu: Use HTTPS for www.boost.org.
* gnu/packages/bioinformatics.scm (libgff)[license]: Use HTTPS.
* gnu/packages/boost.scm (boost-sync)[license]: Likewise.
(boost)[license]: Likewise.
[home-page]: Likewise, and use canonical ‘www’ subdomain.
Diffstat (limited to 'gnu/packages/boost.scm')
-rw-r--r--gnu/packages/boost.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index d347674abb..cdfbda6740 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -106,12 +106,12 @@
            (lambda* (#:key outputs make-flags #:allow-other-keys)
              (zero? (apply system* "./b2" "install" make-flags)))))))
 
-    (home-page "http://boost.org")
+    (home-page "https://www.boost.org")
     (synopsis "Peer-reviewed portable C++ source libraries")
     (description
      "A collection of libraries intended to be widely useful, and usable
 across a broad spectrum of applications.")
-    (license (license:x11-style "http://www.boost.org/LICENSE_1_0.txt"
+    (license (license:x11-style "https://www.boost.org/LICENSE_1_0.txt"
                                 "Some components have other similar licences."))))
 
 (define-public boost-1.66
@@ -158,7 +158,7 @@ across a broad spectrum of applications.")
       (description "The Boost.Sync library provides mutexes, semaphores, locks
 and events and other thread related facilities.  Boost.Sync originated from
 Boost.Thread.")
-      (license (license:x11-style "http://www.boost.org/LICENSE_1_0.txt")))))
+      (license (license:x11-style "https://www.boost.org/LICENSE_1_0.txt")))))
 
 (define-public mdds
   (package