summary refs log tree commit diff
path: root/gnu/packages/bootloaders.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-08-12 00:30:27 +0200
committerMarius Bakke <marius@gnu.org>2021-08-12 00:30:27 +0200
commitc4133c43c7cfe2476ebfae87f9e4d10d96de9bc7 (patch)
tree47bd773d2f434384b54e56916c1a287dd8e51511 /gnu/packages/bootloaders.scm
parentffa01e68859bb7a6daa9fcffdc8d77ca35db4bc0 (diff)
parent4eb0a5146ae5a195a29c79f586fcc1e58f7fa69b (diff)
downloadguix-c4133c43c7cfe2476ebfae87f9e4d10d96de9bc7.tar.gz
Merge branch 'master' into core-updates-frozen
 Conflicts:
	gnu/packages/algebra.scm
	gnu/packages/games.scm
	gnu/packages/golang.scm
	gnu/packages/kerberos.scm
	gnu/packages/mail.scm
	gnu/packages/python.scm
	gnu/packages/ruby.scm
	gnu/packages/scheme.scm
	gnu/packages/tex.scm
	gnu/packages/tls.scm
	gnu/packages/version-control.scm
Diffstat (limited to 'gnu/packages/bootloaders.scm')
-rw-r--r--gnu/packages/bootloaders.scm54
1 files changed, 21 insertions, 33 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index d8d1691801..e75c37b0f8 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -56,6 +56,7 @@
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
+  #:use-module (gnu packages python-crypto)
   #:use-module (gnu packages texinfo)
   #:use-module (gnu packages tls)
   #:use-module (gnu packages sdl)
@@ -492,20 +493,26 @@ tree binary files.  These are board description files used by Linux and BSD.")
   ;; and https://patchwork.ozlabs.org/project/uboot/patch/20210406151059.1187379-1-icenowy@aosc.io
   (search-patch "u-boot-rockchip-inno-usb.patch"))
 
+(define %u-boot-sifive-prevent-relocating-initrd-fdt
+  ;; Fix boot in 2021.07 on Hifive unmatched, see
+  ;; https://bugs.launchpad.net/ubuntu/+source/u-boot/+bug/1937246
+  (search-patch "u-boot-sifive-prevent-reloc-initrd-fdt.patch"))
+
 (define u-boot
   (package
     (name "u-boot")
-    (version "2021.04")
+    (version "2021.07")
     (source (origin
 	      (patches
-               (list %u-boot-rockchip-inno-usb-patch))
+               (list %u-boot-rockchip-inno-usb-patch
+                     %u-boot-sifive-prevent-relocating-initrd-fdt))
               (method url-fetch)
               (uri (string-append
                     "https://ftp.denx.de/pub/u-boot/"
                     "u-boot-" version ".tar.bz2"))
               (sha256
                (base32
-                "06p1vymf0dl6jc2xy5w7p42mpgppa46lmpm2ishmgsycnldqnhqd"))))
+                "0zm7igkdnz0w4ir8rfl2dislfrl0ip104grs5hvd30a5wkm7wari"))))
     (native-inputs
      `(("bc" ,bc)
        ("bison" ,bison)
@@ -515,6 +522,7 @@ tree binary files.  These are board description files used by Linux and BSD.")
        ("perl" ,perl)
        ("python" ,python)
        ("python-coverage" ,python-coverage)
+       ("python-pycryptodomex" ,python-pycryptodomex)
        ("python-pytest" ,python-pytest)
        ("swig" ,swig)))
     (build-system  gnu-build-system)
@@ -524,21 +532,6 @@ tree binary files.  These are board description files used by Linux and BSD.")
 also initializes the boards (RAM etc).")
     (license license:gpl2+)))
 
-(define-public u-boot-2021.07
-  (package
-   (inherit u-boot)
-   (version "2021.07-rc4")
-   (source (origin
-             (patches
-               (list %u-boot-rockchip-inno-usb-patch))
-            (method url-fetch)
-            (uri (string-append
-                  "https://ftp.denx.de/pub/u-boot/"
-                  "u-boot-" version ".tar.bz2"))
-            (sha256
-             (base32
-              "0bnsywgy2b0jxim5h9dc807lqk5kq8hvgf4lcsmffnc0hf4isv8p"))))))
-
 (define-public u-boot-tools
   (package
     (inherit u-boot)
@@ -567,9 +560,13 @@ also initializes the boards (RAM etc).")
               ;; This test would require git.
               (("\\./tools/patman/patman") (which "true"))
               ;; FIXME: test fails, needs further investiation
-              (("run_test \"binman\"") ": run_test \"binman\"")
+              (("run_test \"binman\"") "# run_test \"binman\"")
+              ;; FIXME: test_spl fails, needs further investiation
+              (("test_ofplatdata or test_handoff or test_spl")
+                "test_ofplatdata or test_handoff")
               ;; FIXME: code coverage not working
-              (("run_test \"binman code coverage\"") ": run_test \"binman code coverage\"")
+              (("run_test \"binman code coverage\"")
+               "# run_test \"binman code coverage\"")
               ;; This test would require internet access.
               (("\\./tools/buildman/buildman") (which "true")))
              (substitute* "test/py/tests/test_sandbox_exit.py"
@@ -715,9 +712,6 @@ board-independent tools.")))
                   uboot-files)
                  #t)))))))))
 
-(define-public u-boot-vexpress
-  (make-u-boot-package "vexpress_ca9x4" "arm-linux-gnueabihf"))
-
 (define-public u-boot-malta
   (make-u-boot-package "malta" "mips64el-linux-gnuabi64"))
 
@@ -873,15 +867,11 @@ to Novena upstream, does not load u-boot.img from the first partition.")
                 (patches
                  (search-patches "u-boot-riscv64-fix-extlinux.patch")))))))
 
-(define-public u-boot-sifive-fu540
-  (make-u-boot-package "sifive_fu540" "riscv64-linux-gnu"))
+(define-public u-boot-sifive-unleashed
+  (make-u-boot-package "sifive_unleashed" "riscv64-linux-gnu"))
 
 (define-public u-boot-sifive-unmatched
-  (let ((base (make-u-boot-package "sifive_unmatched" "riscv64-linux-gnu")))
-    (package
-      (inherit base)
-      (version (package-version u-boot-2021.07))
-      (source (package-source u-boot-2021.07)))))
+  (make-u-boot-package "sifive_unmatched" "riscv64-linux-gnu"))
 
 (define-public u-boot-rock64-rk3328
   (let ((base (make-u-boot-package "rock64-rk3328" "aarch64-linux-gnu")))
@@ -939,9 +929,7 @@ to Novena upstream, does not load u-boot.img from the first partition.")
 (define-public u-boot-pinebook-pro-rk3399
   (let ((base (make-u-boot-package "pinebook-pro-rk3399" "aarch64-linux-gnu")))
     (package
-     (inherit base)
-      (version (package-version u-boot-2021.07))
-      (source (package-source u-boot-2021.07))
+      (inherit base)
       (arguments
         (substitute-keyword-arguments (package-arguments base)
           ((#:phases phases)