summary refs log tree commit diff
path: root/gnu/packages/bootloaders.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2021-02-11 19:12:36 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2021-02-11 19:12:36 +0100
commitabd318ff4b741eac11227778bf2e569ee7b186ff (patch)
tree6abc09a3e01914d891124e9d0dda0f4e0979c485 /gnu/packages/bootloaders.scm
parent71cb6dfe10540718eb337e7e2248fc809394894b (diff)
parentc5dc87fee840ad620b01637dc4f9ffa5efc9270c (diff)
downloadguix-abd318ff4b741eac11227778bf2e569ee7b186ff.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/bootloaders.scm')
-rw-r--r--gnu/packages/bootloaders.scm46
1 files changed, 21 insertions, 25 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 88abe29a1e..99281b2cc6 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -478,7 +478,7 @@ tree binary files.  These are board description files used by Linux and BSD.")
 (define u-boot
   (package
     (name "u-boot")
-    (version "2020.10")
+    (version "2021.01")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -486,7 +486,7 @@ tree binary files.  These are board description files used by Linux and BSD.")
                     "u-boot-" version ".tar.bz2"))
               (sha256
                (base32
-                "08m6f1bh4pdcqbxf983qdb66ccd5vak5cbzc114yf3jwq2yinj0d"))))
+                "0m04glv9kn3bhs62sn675w60wkrl4m3a4hnbnnw67s3l198y21xl"))))
     (native-inputs
      `(("bc" ,bc)
        ("bison" ,bison)
@@ -813,30 +813,19 @@ to Novena upstream, does not load u-boot.img from the first partition.")
     (package
       (inherit base)
       (arguments
-       (substitute-keyword-arguments (package-arguments base)
-         ((#:phases phases)
-          `(modify-phases ,phases
-             (add-after 'unpack 'set-environment
-               (lambda* (#:key inputs #:allow-other-keys)
-                 ;; Need to copy the firmware into u-boot build
-                 ;; directory.
-                 (copy-file (string-append (assoc-ref inputs "firmware")
-                                           "/bl31.bin") "bl31-rk3399.bin")
-                 (copy-file (string-append (assoc-ref inputs "firmware-m0")
-                                           "/rk3399m0.bin") "rk3399m0.bin")
-                 #t))
-             (add-after 'build 'build-itb
-               (lambda* (#:key make-flags #:allow-other-keys)
-                 ;; The u-boot.itb is not built by default.
-                 (apply invoke "make" `(,@make-flags ,"u-boot.itb"))))
-             (add-after 'build-itb 'build-rksd
-               (lambda* (#:key inputs #:allow-other-keys)
-                 ;; Build Rockchip SD card images.
-                 (invoke "./tools/mkimage" "-T" "rksd" "-n" "rk3399" "-d"
-                         "spl/u-boot-spl.bin" "u-boot-spl.rksd")))))))
+        (substitute-keyword-arguments (package-arguments base)
+          ((#:phases phases)
+           `(modify-phases ,phases
+              (add-after 'unpack 'set-environment
+                (lambda* (#:key inputs #:allow-other-keys)
+                  (setenv "BL31" (string-append (assoc-ref inputs "firmware")
+                                                "/bl31.elf"))
+                  #t))
+              ;; Phases do not succeed on the bl31 ELF.
+              (delete 'strip)
+              (delete 'validate-runpath)))))
       (native-inputs
-       `(("firmware" ,arm-trusted-firmware-puma-rk3399)
-         ("firmware-m0" ,rk3399-cortex-m0)
+       `(("firmware" ,arm-trusted-firmware-rk3399)
          ,@(package-native-inputs base))))))
 
 (define-public u-boot-qemu-riscv64
@@ -927,6 +916,13 @@ to Novena upstream, does not load u-boot.img from the first partition.")
         (substitute-keyword-arguments (package-arguments base)
           ((#:phases phases)
            `(modify-phases ,phases
+              (add-after 'unpack 'patch-pinebook-pro-config
+                ;; Fix regression in 2020.10 causing freezes on boot with USB boot enabled.
+                ;; See https://gitlab.manjaro.org/manjaro-arm/packages/core/uboot-rockpro64/-/issues/4
+                (lambda _
+                  (substitute* "configs/pinebook-pro-rk3399_defconfig"
+                    (("CONFIG_USE_PREBOOT=y") "CONFIG_USE_PREBOOT=n"))
+                  #t))
               (add-after 'unpack 'set-environment
                 (lambda* (#:key inputs #:allow-other-keys)
                   (setenv "BL31" (string-append (assoc-ref inputs "firmware")