summary refs log tree commit diff
path: root/gnu/packages/bootloaders.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-05-15 16:51:01 -0400
committerLeo Famulari <leo@famulari.name>2017-05-15 17:07:12 -0400
commit5e54f4adda6b636b03b252804565f4d845d03658 (patch)
treefc0bbd7d618820f670125052eb038235b8ca7504 /gnu/packages/bootloaders.scm
parent93fabf59962aeb15981bd547850de1dab69eccfb (diff)
downloadguix-5e54f4adda6b636b03b252804565f4d845d03658.tar.gz
gnu: flex-2.6.1: Remove variable.
* gnu/packages/flex.scm (flex-2.6.1): Remove variable.
* gnu/packages/bootloaders.scm (grub, dtc): Use flex instead of flex-2.6.1.
* gnu/packages/embedded.scm (propeller-binutils, binutils-vc4): Likewise.
* gnu/packages/maths.scm (scotch): Likewise.
* gnu/packages/wine.scm (wine): Likewise.
Diffstat (limited to 'gnu/packages/bootloaders.scm')
-rw-r--r--gnu/packages/bootloaders.scm7
1 files changed, 2 insertions, 5 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 98afc6a7c1..572186bea7 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -114,10 +114,7 @@
     (native-inputs
      `(("unifont" ,unifont)
        ("bison" ,bison)
-       ;; Due to a bug in flex >= 2.6.2, GRUB must be built with an older flex:
-       ;; <http://lists.gnu.org/archive/html/grub-devel/2017-02/msg00133.html>
-       ;; TODO Try building with flex > 2.6.3.
-       ("flex" ,flex-2.6.1)
+       ("flex" ,flex)
        ("texinfo" ,texinfo)
        ("help2man" ,help2man)
 
@@ -240,7 +237,7 @@ menu to select one of the installed operating systems.")
     (build-system gnu-build-system)
     (native-inputs
      `(("bison" ,bison)
-       ("flex" ,flex-2.6.1))) ; A bug in flex prevents building with flex-2.6.3.
+       ("flex" ,flex)))
     (arguments
      `(#:make-flags
        (list "CC=gcc"