summary refs log tree commit diff
path: root/gnu/packages/bootloaders.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2018-01-20 15:49:03 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2018-01-20 20:33:10 +0100
commitf074f5e88ccdb8c5c959d1a60cc03b4c2fc3d823 (patch)
tree42524062ccec66c1ab0d041d9acf296468b65e5d /gnu/packages/bootloaders.scm
parent30aeb846d7516d534aebeee76be4a920195e8d50 (diff)
downloadguix-f074f5e88ccdb8c5c959d1a60cc03b4c2fc3d823.tar.gz
gnu: u-boot: Update to 2018.01.
* gnu/packages/bootloaders.scm (define-module): Import (gnu packages gcc).
(u-boot): Update to 2018.01.
[native-inputs]: Add swig.  Remove dtc.
(make-u-boot-package): Use gcc-7.
Diffstat (limited to 'gnu/packages/bootloaders.scm')
-rw-r--r--gnu/packages/bootloaders.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 50e55d7d00..4d1f784648 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -37,6 +37,7 @@
   #:use-module (gnu packages disk)
   #:use-module (gnu packages flex)
   #:use-module (gnu packages fontutils)
+  #:use-module (gnu packages gcc)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages man)
@@ -335,7 +336,7 @@ tree binary files.  These are board description files used by Linux and BSD.")
 (define u-boot
   (package
     (name "u-boot")
-    (version "2017.11")
+    (version "2018.01")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -343,11 +344,12 @@ tree binary files.  These are board description files used by Linux and BSD.")
                     "u-boot-" version ".tar.bz2"))
               (sha256
                (base32
-                "01bcsah5imy6m3fbjwhqywxg0pfk5fl8ks9ylb7kv3zmrb9qy0ba"))))
+                "1nidnnjprgxdhiiz7gmaj8cgcf52l5gbv64cmzjq4gmkjirmk3wk"))))
     (native-inputs
      `(("bc" ,bc)
-       ("dtc" ,dtc)
-       ("python-2" ,python-2)))
+       ;("dtc" ,dtc) ; they have their own incompatible copy.
+       ("python-2" ,python-2)
+       ("swig" ,swig)))
     (build-system  gnu-build-system)
     (home-page "http://www.denx.de/wiki/U-Boot/")
     (synopsis "ARM bootloader")
@@ -366,7 +368,7 @@ also initializes the boards (RAM etc).")
       (name (string-append "u-boot-" (string-downcase board)))
       (native-inputs
        `(,@(if (not same-arch?)
-             `(("cross-gcc" ,(cross-gcc triplet))
+             `(("cross-gcc" ,(cross-gcc triplet #:xgcc gcc-7))
                ("cross-binutils" ,(cross-binutils triplet)))
              '())
          ,@(package-native-inputs u-boot)))