summary refs log tree commit diff
path: root/gnu/packages/bootloaders.scm
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2020-07-09 16:07:30 -0700
committerVagrant Cascadian <vagrant@debian.org>2020-07-09 17:22:18 -0700
commitbce3c9748b4ba47cdb915492e5c7baaf3d3a2511 (patch)
treeda98698d6ab99a8320a3cd99b27a677577a7982f /gnu/packages/bootloaders.scm
parent8d49c80b69258115da47d868cbd5b45c5d6b2180 (diff)
downloadguix-bce3c9748b4ba47cdb915492e5c7baaf3d3a2511.tar.gz
gnu: u-boot: Update to 2020.07.
* gnu/packages/bootloaders (u-boot): Update to 2020.07.
  (u-boot-pinebook-pro-rk3399): Remove patches.
* gnu/packages/patches:
  u-boot-DT-for-Pinebook-Pro.patch, u-boot-add-boe-nv140fhmn49-display.patch,
  u-boot-gpio-keys-binding-cons.patch, u-boot-leds-common-binding-con.patch,
  u-boot-support-Pinebook-Pro-laptop.patch,
  u-boot-video-rockchip-fix-build.patch: Remove patches.
  u-boot-riscv64-fix-extlinux.patch: Refresh patch.
* gnu/local.mk (dist_patch_DATA): Update accordingly.
Diffstat (limited to 'gnu/packages/bootloaders.scm')
-rw-r--r--gnu/packages/bootloaders.scm13
1 files changed, 2 insertions, 11 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 07b406b42a..769238203c 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -446,7 +446,7 @@ tree binary files.  These are board description files used by Linux and BSD.")
 (define u-boot
   (package
     (name "u-boot")
-    (version "2020.04")
+    (version "2020.07")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -454,7 +454,7 @@ tree binary files.  These are board description files used by Linux and BSD.")
                     "u-boot-" version ".tar.bz2"))
               (sha256
                (base32
-                "0wjkasnz87q86hx93inspdjfjsinmxi87bcvj30c773x0fpjlwzy"))))
+                "0sjzy262x93aaqd6z24ziaq19xjjjk5f577ivf768vmvwsgbzxf1"))))
     (native-inputs
      `(("bc" ,bc)
        ("bison" ,bison)
@@ -885,15 +885,6 @@ to Novena upstream, does not load u-boot.img from the first partition.")
   (let ((base (make-u-boot-package "pinebook-pro-rk3399" "aarch64-linux-gnu")))
     (package
      (inherit base)
-     (source (origin
-              (inherit (package-source u-boot))
-              (patches
-               (search-patches "u-boot-add-boe-nv140fhmn49-display.patch"
-                               "u-boot-gpio-keys-binding-cons.patch"
-                               "u-boot-leds-common-binding-con.patch"
-                               "u-boot-DT-for-Pinebook-Pro.patch"
-                               "u-boot-support-Pinebook-Pro-laptop.patch"
-                               "u-boot-video-rockchip-fix-build.patch"))))
       (arguments
         (substitute-keyword-arguments (package-arguments base)
           ((#:phases phases)