summary refs log tree commit diff
path: root/gnu/packages/bootloaders.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-08-18 13:02:21 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2019-09-04 18:14:25 +0200
commit7c35342472338ae00141f2bcb64ec7073eb2be21 (patch)
treef8c2d93a0e82935c962a864cd14e428f9528fce1 /gnu/packages/bootloaders.scm
parent58a75996ecdd09431f943c4d55b199b8aceea72d (diff)
downloadguix-7c35342472338ae00141f2bcb64ec7073eb2be21.tar.gz
gnu: grub: Fix cross-compilation.
* gnu/packages/bootloaders.scm (grub)[arguments]: Search for unifont in both
native-inputs and inputs.
Diffstat (limited to 'gnu/packages/bootloaders.scm')
-rw-r--r--gnu/packages/bootloaders.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 41a2de9706..b235e1bc78 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -99,7 +99,7 @@
        (list "PYTHON=true")
        #:phases (modify-phases %standard-phases
                   (add-after 'unpack 'patch-stuff
-                   (lambda* (#:key inputs #:allow-other-keys)
+                   (lambda* (#:key native-inputs inputs #:allow-other-keys)
                      (substitute* "grub-core/Makefile.in"
                        (("/bin/sh") (which "sh")))
 
@@ -114,7 +114,9 @@
                                        "/sbin/mdadm\"")))
 
                      ;; Make the font visible.
-                     (copy-file (assoc-ref inputs "unifont") "unifont.bdf.gz")
+                     (copy-file (assoc-ref (or native-inputs inputs)
+                                           "unifont")
+                                "unifont.bdf.gz")
                      (system* "gunzip" "unifont.bdf.gz")
 
                      ;; Give the absolute file name of 'ckbcomp'.