summary refs log tree commit diff
path: root/gnu/packages/bootloaders.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-02-24 19:04:13 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-02-24 19:04:13 +0100
commit5f9b018aa8334d5a38ac83ebe040ba36ce511305 (patch)
tree1e67a1fd0444e6073f7d33091322528ccc8c3849 /gnu/packages/bootloaders.scm
parentfb6550058e167c25bbcbe0ebcf51590f83506f23 (diff)
parentf09cb93e3a2310f7726cb98fa5679c1a8483c39f (diff)
downloadguix-5f9b018aa8334d5a38ac83ebe040ba36ce511305.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/bootloaders.scm')
-rw-r--r--gnu/packages/bootloaders.scm18
1 files changed, 17 insertions, 1 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 59eb22f242..9ea8748a5b 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -71,6 +71,22 @@
      (base32
       "0p2vhnc18cnbmb39vq4m7hzv4mhnm2l0a2s7gx3ar277fwng3hys"))))
 
+;; The GRUB test suite fails with later versions of Qemu, so we
+;; keep it at 2.10 for now.  See
+;; <https://lists.gnu.org/archive/html/bug-grub/2018-02/msg00004.html>.
+;; TODO: When grub no longer needs this version, move to gnu/packages/debug.scm.
+(define qemu-minimal-2.10
+  (package
+    (inherit qemu-minimal)
+    (version "2.10.2")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://download.qemu.org/qemu-"
+                                  version ".tar.xz"))
+              (sha256
+               (base32
+                "17w21spvaxaidi2am5lpsln8yjpyp2zi3s3gc6nsxj5arlgamzgw"))))))
+
 (define-public grub
   (package
     (name "grub")
@@ -144,7 +160,7 @@
        ;; Dependencies for the test suite.  The "real" QEMU is needed here,
        ;; because several targets are used.
        ("parted" ,parted)
-       ("qemu" ,qemu-minimal)
+       ("qemu" ,qemu-minimal-2.10)
        ("xorriso" ,xorriso)))
     (home-page "https://www.gnu.org/software/grub/")
     (synopsis "GRand Unified Boot loader")