summary refs log tree commit diff
path: root/gnu/packages/bootloaders.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-03-07 22:38:35 -0500
committerLeo Famulari <leo@famulari.name>2017-03-08 00:07:11 -0500
commitaf50d389c5ceaf978182c8d783a4d0e76c56655f (patch)
tree1098ba9e91ef332f20e2d7cb137a565977cdea6f /gnu/packages/bootloaders.scm
parentaac67f210df820e84cdd380dc061e417ebd2154e (diff)
downloadguix-af50d389c5ceaf978182c8d783a4d0e76c56655f.tar.gz
gnu: grub: Fix build failure with recent flex.
* gnu/packages/bootloaders.scm (grub)[native-inputs]: Use flex-2.6.1.
Diffstat (limited to 'gnu/packages/bootloaders.scm')
-rw-r--r--gnu/packages/bootloaders.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 16cb7b4c0b..86a776910a 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -27,7 +27,6 @@
   #:use-module (gnu packages admin)
   #:use-module ((gnu packages algebra) #:select (bc))
   #:use-module (gnu packages assembly)
-  #:use-module (gnu packages flex)
   #:use-module (gnu packages disk)
   #:use-module (gnu packages bison)
   #:use-module (gnu packages cdrom)
@@ -115,7 +114,10 @@
     (native-inputs
      `(("unifont" ,unifont)
        ("bison" ,bison)
-       ("flex" ,flex)
+       ;; Due to a bug in flex >= 2.6.2, GRUB must be built with an older flex:
+       ;; <http://lists.gnu.org/archive/html/grub-devel/2017-02/msg00133.html>
+       ;; TODO Try building with flex > 2.6.3.
+       ("flex" ,flex-2.6.1)
        ("texinfo" ,texinfo)
        ("help2man" ,help2man)