summary refs log tree commit diff
path: root/gnu/packages/bootstrap.scm
diff options
context:
space:
mode:
authorJan Nieuwenhuizen <janneke@gnu.org>2018-09-19 17:23:09 +0200
committerJan Nieuwenhuizen <janneke@gnu.org>2018-09-23 09:46:26 +0200
commiteb4434598cbf8d04a3e5b1995be50fe3b44f0507 (patch)
tree73ec77e12679d81a84f10ccf2db76a32ba861ed9 /gnu/packages/bootstrap.scm
parenta243722c5b8d50b4f0e3f9717ca71aa43dfc56a3 (diff)
downloadguix-eb4434598cbf8d04a3e5b1995be50fe3b44f0507.tar.gz
bootstrap: Reduced Binary Seed bootstrap for x86_64 too.
* gnu/packages/bootstrap.scm (%bootstrap-inputs): Replace %bootstrap-libc,
%bootstrap-gcc, and %bootstrap-binutils with Mes seeds for x86_64 too.
* gnu/packages/commencement.scm (tcc-boot0, tcc-boot, gcc-mesboot1,
gcc-mesboot1-wrapper, m4-mesboot, %bootstrap-inputs+toolchain,
libstdc++-boot0, gcc-boot0, bison-boot0): For x86_64-linux, use i686-linux
glibc-dynamic-linker and Mes bootstrap settings.
(gcc-boot0-intermediate-wrapped): New variable, extract from
static-bash-for-glibc.
(static-bash-for-glibc): Use it.
(gcc-final): Copy gmp&co phase from gcc-boot0, inherit other arguments
from gcc; avoid i686-linux impersonation from gcc-boot0.
* doc/guix.texi (Bootstrapping, Reduced Binary Seed Bootstrap): Note
x86_64-linux also as Reduced Binary Seed bootstrap.
Diffstat (limited to 'gnu/packages/bootstrap.scm')
-rw-r--r--gnu/packages/bootstrap.scm19
1 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
index 83dd2f860f..c52b4302e1 100644
--- a/gnu/packages/bootstrap.scm
+++ b/gnu/packages/bootstrap.scm
@@ -656,15 +656,16 @@ exec ~a/bin/.gcc-wrapped -B~a/lib \
   ;; The initial, pre-built inputs.  From now on, we can start building our
   ;; own packages.
   `(,@(match (%current-system)
-        ("i686-linux" `(("linux-libre-headers" ,%bootstrap-linux-libre-headers)
-                        ("mescc-tools-seed" ,%mescc-tools-seed)
-                        ("mes-seed" ,%mes-seed)
-                        ("srfi-43" ,%srfi-43 )
-                        ("tinycc-seed" ,%tinycc-seed)))
-
-        (_  `(("libc" ,%bootstrap-glibc)
-              ("gcc" ,%bootstrap-gcc)
-              ("binutils" ,%bootstrap-binutils))))
+        ((or "i686-linux" "x86_64-linux")
+         `(("linux-libre-headers" ,%bootstrap-linux-libre-headers)
+           ("mescc-tools-seed" ,%mescc-tools-seed)
+           ("mes-seed" ,%mes-seed)
+           ("srfi-43" ,%srfi-43 )
+           ("tinycc-seed" ,%tinycc-seed)))
+        (_
+         `(("libc" ,%bootstrap-glibc)
+           ("gcc" ,%bootstrap-gcc)
+           ("binutils" ,%bootstrap-binutils))))
     ("coreutils&co" ,%bootstrap-coreutils&co)
 
     ;; In gnu-build-system.scm, we rely on the availability of Bash.