summary refs log tree commit diff
path: root/gnu/packages/bootstrap.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-09-24 19:08:54 +0200
committerLudovic Courtès <ludo@gnu.org>2014-09-24 19:08:54 +0200
commitce517b20d4c80c5b59151fe20e887e3836f9dc57 (patch)
treeedef500317a1ca957649707d9f3726a421fdca50 /gnu/packages/bootstrap.scm
parent27afb11a2284aaea187897c0fe32e1d50b49d654 (diff)
downloadguix-ce517b20d4c80c5b59151fe20e887e3836f9dc57.tar.gz
gnu: bootstrap: Correctly handle patches that are origins.
* gnu/packages/bootstrap.scm (bootstrap-origin): Rewrite the patches of
  SOURCES that are also origins.
Diffstat (limited to 'gnu/packages/bootstrap.scm')
-rw-r--r--gnu/packages/bootstrap.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
index 981cde9f2b..71ccb19597 100644
--- a/gnu/packages/bootstrap.scm
+++ b/gnu/packages/bootstrap.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -78,7 +78,14 @@
                      (boot url-fetch))
                     (else orig-method)))
       (patch-guile %bootstrap-guile)
-      (patch-inputs %bootstrap-patch-inputs))))
+      (patch-inputs %bootstrap-patch-inputs)
+
+      ;; Patches can be origins as well, so process them.
+      (patches (map (match-lambda
+                     ((? origin? patch)
+                      (bootstrap-origin patch))
+                     (patch patch))
+                    (origin-patches source))))))
 
 (define (package-from-tarball name source program-to-test description)
   "Return a package that correspond to the extraction of SOURCE.