summary refs log tree commit diff
path: root/gnu/packages/build-tools.scm
diff options
context:
space:
mode:
authorJelle Licht <jlicht@fsfe.org>2023-03-10 12:32:31 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-12 08:26:28 -0400
commit5c94582a15b67c90098d406b48b63563718c3916 (patch)
treed85e1f6900aad6d021b0579565f4870fd7e6db3e /gnu/packages/build-tools.scm
parentcd451a3971d23c7b08f9e45f6fbde64390db0a03 (diff)
downloadguix-5c94582a15b67c90098d406b48b63563718c3916.tar.gz
gnu: Add pdpmake.
* gnu/packages/build-tools.scm (pdpmake): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/build-tools.scm')
-rw-r--r--gnu/packages/build-tools.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/build-tools.scm b/gnu/packages/build-tools.scm
index 23b8c763d4..4c093a7b45 100644
--- a/gnu/packages/build-tools.scm
+++ b/gnu/packages/build-tools.scm
@@ -1019,3 +1019,38 @@ maintenance-related files, for convenience.")
    #:version "2022-12-31"
    #:commit "875461ffdf58ac04677957b4ae4160465b83b940"
    #:hash (base32 "0bf7a6wdns9c5wwv60qfcn9llg0j6jz5ryd2qgsqqx2i6xkmp77c")))
+
+(define-public pdpmake
+  (package
+    (name "pdpmake")
+    (version "1.4.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/rmyorston/pdpmake")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0fjx5imd7s0h0yy8h2qc4vkdq7kxqcljnrw6h8n88720xha5z3cb"))))
+    (build-system gnu-build-system)
+    (arguments
+     (list
+      #:test-target "test"
+      #:parallel-tests? #f
+      #:make-flags
+      #~(list "DESTDIR=\"\""
+              (string-append "CC=" #$(cc-for-target))
+              (string-append "PREFIX=" #$output))
+      #:phases
+      #~(modify-phases %standard-phases
+          (delete 'configure))))
+    (home-page "https://frippery.org/make/")
+    (synopsis "POSIX make")
+    (description
+     "This package contains an implementation of POSIX make.  The default
+configuration enables extensions.  Generally these extensions are compatible
+with GNU make.")
+    ;; pdpmake is distributed under the public domain, but the sources include
+    ;; tests under the GPL license version 2.
+    (license (list license:gpl2 license:public-domain))))