summary refs log tree commit diff
path: root/gnu/packages/build-tools.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-03-09 15:29:19 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-03-12 17:27:07 +0100
commit3f6c185e0c2e800efed15761f5769761c8405289 (patch)
tree4e2473fc7afa33d8eca8eea275125c7a2ffc1067 /gnu/packages/build-tools.scm
parentd31558632cb2d2ca0a5a70000ee5e3e1cbc92948 (diff)
downloadguix-3f6c185e0c2e800efed15761f5769761c8405289.tar.gz
gnu: meson: Update to 0.45.0.
* gnu/packages/build-tools.scm (meson): Update to 0.45.0.
[arguments]: Explicitly disable tests (they were skipped before).
Diffstat (limited to 'gnu/packages/build-tools.scm')
-rw-r--r--gnu/packages/build-tools.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/build-tools.scm b/gnu/packages/build-tools.scm
index 94ca104c9b..6a759f2b71 100644
--- a/gnu/packages/build-tools.scm
+++ b/gnu/packages/build-tools.scm
@@ -71,7 +71,7 @@ makes a few sacrifices to acquire fast full and incremental build times.")
 (define-public meson
   (package
     (name "meson")
-    (version "0.44.0")
+    (version "0.45.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://github.com/mesonbuild/meson/"
@@ -79,10 +79,14 @@ makes a few sacrifices to acquire fast full and incremental build times.")
                                   version ".tar.gz"))
               (sha256
                (base32
-                "06r8limj38mv884s5riiz6lpzw37cvhbf9jd0smzcbi7fwmv3yah"))))
+                "1r3wlimllakrswx2rb4mbdk1iricqk6myvdvib6dkyx362yanm9l"))))
     (build-system python-build-system)
     (arguments
-     `(#:phases (modify-phases %standard-phases
+     `(;; FIXME: Tests require many additional inputs, a fix for the RUNPATH
+       ;; patch in meson-for-build, and patching many hard-coded file system
+       ;; locations in "run_unittests.py".
+       #:tests? #f
+       #:phases (modify-phases %standard-phases
                   ;; Meson calls the various executables in out/bin through the
                   ;; Python interpreter, so we cannot use the shell wrapper.
                   (delete 'wrap))))