summary refs log tree commit diff
path: root/gnu/packages/c.scm
diff options
context:
space:
mode:
authorJean-Pierre De Jesus DIAZ <jean@foundationdevices.com>2023-06-14 14:20:18 +0200
committerLudovic Courtès <ludo@gnu.org>2023-06-21 00:10:50 +0200
commit1a0ff5cd83d3257efcab64740a1322de51fbc4a1 (patch)
tree5684c0d74221004de66fca19cb28cbecb3e6addc /gnu/packages/c.scm
parent105781d3d3e73d0eb5b5f3aeb0d5ad743aa89a80 (diff)
downloadguix-1a0ff5cd83d3257efcab64740a1322de51fbc4a1.tar.gz
gnu: Add tomlc99.
* gnu/packages/c.scm (tomlc99): New variable.

Signed-off-by: Jean-Pierre De Jesus DIAZ <jean@foundationdevices.com>
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/c.scm')
-rw-r--r--gnu/packages/c.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index e8bde0133d..9e5b511b98 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -18,6 +18,7 @@
 ;;; Copyright © 2022 Ekaitz Zarraga <ekaitz@elenq.tech>
 ;;; Copyright © 2022 ( <paren@disroot.org>
 ;;; Copyright © 2023 zamfofex <zamfofex@twdb.moe>
+;;; Copyright © 2023 Foundation Devices, Inc. <hello@foundationdevices.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -241,6 +242,47 @@ standard.")
       ;; (if ever) complete.  See the RELICENSING file for more information.
       (license license:lgpl2.1+))))
 
+(define-public tomlc99
+  (let ((revision "0")
+        (commit "52e9c039c5418a100605c2db1282590511fa891b"))
+    (package
+      (name "tomlc99")
+      (version (git-version "1.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/cktan/tomlc99")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1zrn5mmd1ysxma96jzrq50xqypbs3rhk6dwlj1wcjpjz1a4h9wgg"))))
+      (build-system gnu-build-system)
+      (arguments
+       (list #:make-flags #~(list (string-append "CC="
+                                                 #$(cc-for-target))
+                                  (string-append "prefix="
+                                                 #$output))
+             #:phases #~(modify-phases %standard-phases
+                          (delete 'configure)
+                          (replace 'check
+                            (lambda* (#:key tests? make-flags
+                                      #:allow-other-keys)
+                              (when tests?
+                                (apply invoke
+                                       `("make" "-C" "unittest"
+                                         ,@make-flags))
+                                (invoke "./unittest/t1")))))))
+      (home-page "https://github.com/cktan/tomlc99")
+      (synopsis "TOML library for C")
+      (description
+       "This library is a C99 implementation to read
+@acronym{TOML, Tom's Obvious Minimal Language} text documents.
+
+This library is compatible with the @url{https://toml.io/en/v1.0.0,v1.0.0}
+specification of the language.")
+      (license license:expat))))
+
 (define-public pcc
   (package
     (name "pcc")