summary refs log tree commit diff
path: root/gnu/packages/c.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-04 17:30:31 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-04 21:21:10 +0200
commit08e3224909978191849bae10c367e005d84a72e5 (patch)
treecb0c13717e206c23c695bc7641edb2b65eb3fb40 /gnu/packages/c.scm
parent2cced18b7691b495836560807791033141df5d9f (diff)
downloadguix-08e3224909978191849bae10c367e005d84a72e5.tar.gz
gnu: sparse: Update to 0.6.4.
* gnu/packages/c.scm (sparse): Update to 0.6.4.
[arguments]: Don't explicitly return #t from phases.
Diffstat (limited to 'gnu/packages/c.scm')
-rw-r--r--gnu/packages/c.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index 70d1d7355f..7fdac40a97 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -388,7 +388,7 @@ any other grammar rules.")
 (define-public sparse
   (package
     (name "sparse")
-    (version "0.6.3")
+    (version "0.6.4")
     (source (origin
               (method url-fetch)
               (uri
@@ -396,7 +396,7 @@ any other grammar rules.")
                               "sparse-"  version ".tar.xz"))
               (sha256
                (base32
-                "16d8c4dhipjzjf8z4z7pix1pdpqydz0v4r7i345f5s09hjnxpxnl"))))
+                "0z1qds52144nvsdnl82r3zs3vax618v920jmffyyssmwj54qpcka"))))
     (build-system gnu-build-system)
     (inputs `(("perl" ,perl)))
     (arguments
@@ -406,8 +406,7 @@ any other grammar rules.")
                   (add-after 'unpack 'patch-cgcc
                     (lambda _
                       (substitute* "cgcc"
-                        (("'cc'") (string-append "'" (which "gcc") "'")))
-                      #t)))))
+                        (("'cc'") (string-append "'" (which "gcc") "'"))))))))
     (synopsis "Semantic C parser for Linux development")
     (description
      "Sparse is a semantic parser for C and is required for Linux development.