summary refs log tree commit diff
path: root/gnu/packages/calcurse.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-10-24 16:10:49 -0400
committerLeo Famulari <leo@famulari.name>2017-10-25 14:44:38 -0400
commita23dbbff1491759924c027fde1f21f29586793a0 (patch)
tree17bec09fbe9f2840857ce420da6a638c37641d57 /gnu/packages/calcurse.scm
parentc4b542ffd4fadf97141aa6a2989d5bfa530eb2ee (diff)
downloadguix-a23dbbff1491759924c027fde1f21f29586793a0.tar.gz
gnu: calcurse: Used the "fixed" test-only tzdata for tests.
* gnu/packages/calcurse.scm (calcurse)[inputs]: Remove tzdata and add ...
[native-inputs]: tzdata-2017a.
[arguments]: Add tzdata-2017a to #:disallowed-references.
Diffstat (limited to 'gnu/packages/calcurse.scm')
-rw-r--r--gnu/packages/calcurse.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/calcurse.scm b/gnu/packages/calcurse.scm
index 20a9a8fb47..826b1f1d09 100644
--- a/gnu/packages/calcurse.scm
+++ b/gnu/packages/calcurse.scm
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2014, 2015, 2017 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2014, 2015, 2017 Leo Famulari <leo@famulari.name>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -38,13 +39,17 @@
        (base32
         "0il0y06akdqgy0f9p40m4x6arn66nh7sr1w1i41bszycs7div266"))))
     (build-system gnu-build-system)
-    (inputs `(("ncurses" ,ncurses)
-              ("tzdata" ,tzdata)))
+    (inputs `(("ncurses" ,ncurses)))
+    (native-inputs `(("tzdata" ,tzdata-2017a)))
     (arguments
      ;; The ical tests all want to create a ".calcurse" directory, and may
      ;; fail with "cannot create directory '.calcurse': File exists" if run
      ;; concurently.
-     '(#:parallel-tests? #f
+     `(#:parallel-tests? #f
+       ;; Since this tzdata is only used for tests and not referenced by the
+       ;; built package, used the "fixed" obsolete version of tzdata and ensure
+       ;; it does not sneak in to the closure.
+       #:disallowed-references (,tzdata-2017a)
        #:phases (modify-phases %standard-phases
                   (add-before 'check 'check-setup
                     (lambda* (#:key inputs #:allow-other-keys)