summary refs log tree commit diff
path: root/gnu/packages/calcurse.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-03-04 19:02:52 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-03-04 19:07:10 +0100
commit02eae558fc2a71a9425eb8f8698afe452edebb4b (patch)
treef5726850c7c6946232c575cc256e052756894d80 /gnu/packages/calcurse.scm
parentad257ec8b578b21fc36b142396324df9e6613d4a (diff)
downloadguix-02eae558fc2a71a9425eb8f8698afe452edebb4b.tar.gz
gnu: calcurse: Fix documentation directory.
* gnu/packages/calcurse.scm (calcurse)[arguments]: Set ‘--docdir’
in #:configure-flags' and add ‘respect-docdir’ phase to use it.
Diffstat (limited to 'gnu/packages/calcurse.scm')
-rw-r--r--gnu/packages/calcurse.scm16
1 files changed, 13 insertions, 3 deletions
diff --git a/gnu/packages/calcurse.scm b/gnu/packages/calcurse.scm
index 22b54d47ac..0dff9081f0 100644
--- a/gnu/packages/calcurse.scm
+++ b/gnu/packages/calcurse.scm
@@ -1,7 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2014, 2015, 2017 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
-;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -46,15 +46,25 @@
      ;; The ical tests all want to create a ".calcurse" directory, and may
      ;; fail with "cannot create directory '.calcurse': File exists" if run
      ;; concurently.
-     `(#:parallel-tests? #f
+     `(#:configure-flags
+       (list (string-append "--docdir=" (assoc-ref %outputs "out")
+                            "/share/doc/" ,name "-" ,version))
+       #:parallel-tests? #f
        ;; Since this tzdata is only used for tests and not referenced by the
        ;; built package, used the "fixed" obsolete version of tzdata and ensure
        ;; it does not sneak in to the closure.
        #:disallowed-references (,tzdata-for-tests)
        #:phases (modify-phases %standard-phases
+                  (add-after 'unpack 'respect-docdir
+                    ;; doc/Makefile disregards ./configure's --docdir option.
+                    (lambda _
+                      (substitute* "doc/Makefile.in"
+                        (("(docdir =) .*" _ match)
+                         (format "~a @docdir@\n" match)))
+                      #t))
                   (add-before 'check 'check-setup
                     (lambda* (#:key inputs #:allow-other-keys)
-                      (setenv "TZDIR"   ;for test/ical-007.sh
+                      (setenv "TZDIR"   ; for test/ical-007.sh
                               (string-append (assoc-ref inputs "tzdata")
                                              "/share/zoneinfo")))))))
     (home-page "https://www.calcurse.org")