summary refs log tree commit diff
path: root/gnu/packages/calcurse.scm
diff options
context:
space:
mode:
authorEric Bavier <ericbavier@gmail.com>2014-02-19 16:02:32 -0600
committerLudovic Courtès <ludo@gnu.org>2014-02-19 23:27:01 +0100
commita438d540b11f380d9dc69ccebeb1d444311b488c (patch)
treea664c18ffcb467b6441cd963d3ad9c3ab0e6bc24 /gnu/packages/calcurse.scm
parent9038298cbf645cc85ab85e5fe47cab9737a15c50 (diff)
downloadguix-a438d540b11f380d9dc69ccebeb1d444311b488c.tar.gz
gnu: calcurse: New module
* gnu/packages/calcurse.scm: New file
* gnu-system.am (GNU_SYSTEM_MODULES): Add it

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/calcurse.scm')
-rw-r--r--gnu/packages/calcurse.scm49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnu/packages/calcurse.scm b/gnu/packages/calcurse.scm
new file mode 100644
index 0000000000..84dab0c53c
--- /dev/null
+++ b/gnu/packages/calcurse.scm
@@ -0,0 +1,49 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages autogen)
+  #:use-module (guix packages)
+  #:use-module (guix licenses)
+  #:use-module (guix download)
+  #:use-module (guix build-system gnu)
+  #:use-module (gnu packages)
+  #:use-module (gnu packages ncurses))
+
+(define-public calcurse
+  (package
+    (name "calcurse")
+    (version "3.1.4")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append "http://calcurse.org/files/calcurse-"
+                          version ".tar.gz"))
+      (sha256
+       (base32
+        "1qwhffwhfg7bjxrviwlcrhnfw0976d39da8kfspq6dgd9nqv68a1"))))
+    (build-system gnu-build-system)
+    (inputs `(("ncurses" ,ncurses)))
+    (home-page "http://www.calcurse.org")
+    (synopsis "Text-based calendar and scheduling")
+    (description
+     "Calcurse is a text-based calendar and scheduling application. It helps
+keep track of events, appointments and everyday tasks. A configurable
+notification system reminds user of upcoming deadlines, and the curses based
+interface can be customized to suit user needs. All of the commands are
+documented within an online help system.")
+    (license bsd-2)))