summary refs log tree commit diff
path: root/gnu/packages/calcurse.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-11-03 08:07:32 -0400
committerLeo Famulari <leo@famulari.name>2017-11-04 10:32:30 -0400
commitf9c3bd2e0183b777ad3794674a360222c62633b0 (patch)
treed06789f2ef227b11d9144486569d159a4f95c6e9 /gnu/packages/calcurse.scm
parent232ffa842d0c14bccf16ae5aa26537148ad021bd (diff)
downloadguix-f9c3bd2e0183b777ad3794674a360222c62633b0.tar.gz
gnu: Generalize the variable name of the test-only tzdata package.
* gnu/packages/base.scm (tzdata-2017a): Rename variable to tzdata-for-tests.
* gnu/packages/calcurse.scm (calcurse)[native-inputs, arguments]: Adjust
accordingly.
gnu/packages/glib.scm (glib): Likewise.
* gnu/packages/perl.scm (perl-libtime-parsedate): Adjust accordingly and
add tzdata-for-tests #:disallowed-references.
* gnu/packages/statistics.scm (r-minimal): Adjust accordingly.
Diffstat (limited to 'gnu/packages/calcurse.scm')
-rw-r--r--gnu/packages/calcurse.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/calcurse.scm b/gnu/packages/calcurse.scm
index 44e90448cd..93eeaf0ee6 100644
--- a/gnu/packages/calcurse.scm
+++ b/gnu/packages/calcurse.scm
@@ -40,7 +40,7 @@
         "0il0y06akdqgy0f9p40m4x6arn66nh7sr1w1i41bszycs7div266"))))
     (build-system gnu-build-system)
     (inputs `(("ncurses" ,ncurses)))
-    (native-inputs `(("tzdata" ,tzdata-2017a)))
+    (native-inputs `(("tzdata" ,tzdata-for-tests)))
     (arguments
      ;; The ical tests all want to create a ".calcurse" directory, and may
      ;; fail with "cannot create directory '.calcurse': File exists" if run
@@ -49,7 +49,7 @@
        ;; Since this tzdata is only used for tests and not referenced by the
        ;; built package, used the "fixed" obsolete version of tzdata and ensure
        ;; it does not sneak in to the closure.
-       #:disallowed-references (,tzdata-2017a)
+       #:disallowed-references (,tzdata-for-tests)
        #:phases (modify-phases %standard-phases
                   (add-before 'check 'check-setup
                     (lambda* (#:key inputs #:allow-other-keys)