summary refs log tree commit diff
path: root/gnu/packages/calendar.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-05-12 20:50:52 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-05-16 06:10:06 +0300
commit2b193389d243c469e159d0ab5dfc86b5867db05d (patch)
tree0b3f4bf2a74259c5ef0050a999ccab68346d320a /gnu/packages/calendar.scm
parenta2ccaa0d790004c1c303a4421f7494ef73b65bd5 (diff)
downloadguix-2b193389d243c469e159d0ab5dfc86b5867db05d.tar.gz
gnu: libical: Update to 2.0.0.
* gnu/packages/calendar.scm (libical): Update to 2.0.0.
[arguments]: Add configure-flag to add "/lib64" to the rpath.
Diffstat (limited to 'gnu/packages/calendar.scm')
-rw-r--r--gnu/packages/calendar.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scm
index 5ddd358607..ff57ba10b3 100644
--- a/gnu/packages/calendar.scm
+++ b/gnu/packages/calendar.scm
@@ -2,6 +2,7 @@
 ;;; Copyright © 2015 David Thompson <davet@gnu.org>
 ;;; Copyright © 2015, 2016 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2016 Kei Yamashita <kei@openmailbox.org>
+;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -37,7 +38,7 @@
 (define-public libical
   (package
     (name "libical")
-    (version "1.0.1")
+    (version "2.0.0")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -45,10 +46,14 @@
                     version "/libical-" version ".tar.gz"))
               (sha256
                (base32
-                "14lmjj63zyx88rf1z71l0v9ms4c2vpdhmixksjjxgywp5p2f7708"))))
+                "1njn2kr0rrjqv5g3hdhpdzrhankyj4fl1bgn76z3g4n1b7vi2k35"))))
     (build-system cmake-build-system)
     (arguments
      '(#:tests? #f ; test suite appears broken
+       #:configure-flags
+       (list (string-append "-DCMAKE_INSTALL_RPATH="
+                            (assoc-ref %outputs "out") "/lib:"
+                            (assoc-ref %outputs "out") "/lib64"))
        #:phases
        (modify-phases %standard-phases
          (add-before 'configure 'patch-paths