summary refs log tree commit diff
path: root/gnu/packages/calendar.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-09-08 13:37:07 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-09-09 08:23:51 +0300
commit585b72c6f00aff61ff7a89b3159c605b230b88c3 (patch)
tree03b496c752cea957493fc72aa4d3e61bb2bf0676 /gnu/packages/calendar.scm
parent5acf00f99072cd4da8d3ba064f19cc819288d68b (diff)
downloadguix-585b72c6f00aff61ff7a89b3159c605b230b88c3.tar.gz
gnu: Add libhdate.
* gnu/packages/calendar.scm (libhdate): New variable.
Diffstat (limited to 'gnu/packages/calendar.scm')
-rw-r--r--gnu/packages/calendar.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scm
index cf858996e6..0c37caa8e8 100644
--- a/gnu/packages/calendar.scm
+++ b/gnu/packages/calendar.scm
@@ -166,3 +166,24 @@ program to be executed.  It also features: sophisticated date calculation,
 moon phases, sunrise/sunset, Hebrew calendar, alarms, PostScript output and
 proper handling of holidays.")
     (license gpl2)))
+
+(define-public libhdate
+  (package
+    (name "libhdate")
+    (version "1.6.02")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append "mirror://sourceforge/libhdate/libhdate/libhdate-"
+                            version "/" name "-" version ".tar.bz2"))
+        (sha256
+         (base32
+          "0qkpq412p78znw8gckwcx3l0wcss9s0dgw1pvjb1ih2pxf6hm4rw"))))
+    (build-system gnu-build-system)
+    (home-page "http://libhdate.sourceforge.net/")
+    (synopsis "Library to use Hebrew dates")
+    (description "LibHdate is a small library for the Hebrew calendar and times
+of day, written in C, and including bindings for C++, pascal, perl, php, python,
+and ruby.  It includes two illustrative command-line programs, @code{hcal} and
+@code{hdate}, and some snippets and scripts written in the binding languages.")
+    (license gpl3+)))