summary refs log tree commit diff
path: root/gnu/packages/calendar.scm
diff options
context:
space:
mode:
authorStefan Reichoer <stefan@xsteve.at>2016-09-04 01:09:48 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-09-04 16:59:16 +0200
commit696cb41be78e514797c26d9c416c15c66f548364 (patch)
tree0749dcec919497134a6a5a89780405149c0765dd /gnu/packages/calendar.scm
parentadbd7faf412297e48931ba4f7ad9a062d852ab8a (diff)
downloadguix-696cb41be78e514797c26d9c416c15c66f548364.tar.gz
gnu: Add remind.
* gnu/packages/calendar.scm (remind): New variable.
Diffstat (limited to 'gnu/packages/calendar.scm')
-rw-r--r--gnu/packages/calendar.scm34
1 files changed, 33 insertions, 1 deletions
diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scm
index 7f3d05d08e..cf858996e6 100644
--- a/gnu/packages/calendar.scm
+++ b/gnu/packages/calendar.scm
@@ -4,6 +4,7 @@
 ;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016 Troy Sankey <sankeytms@gmail.com>
+;;; Copyright © 2016 Stefan Reichoer <stefan@xsteve.at>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -26,6 +27,7 @@
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build utils)
+  #:use-module (guix build-system gnu)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system python)
   #:use-module (gnu packages base)
@@ -34,7 +36,8 @@
   #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages icu4c)
   #:use-module (gnu packages perl)
-  #:use-module (gnu packages python))
+  #:use-module (gnu packages python)
+  #:use-module (srfi srfi-26))
 
 (define-public libical
   (package
@@ -134,3 +137,32 @@ data units.")
 able to synchronize with CalDAV servers through vdirsyncer.")
     (home-page "http://lostpackets.de/khal/")
     (license expat)))
+
+(define-public remind
+  (package
+    (name "remind")
+    (version "3.1.15")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://www.roaringpenguin.com/files/download/"
+                           "remind-"
+                           (string-join (map (cut string-pad <> 2 #\0)
+                                             (string-split version #\.))
+                                        ".")
+                           ".tar.gz"))
+       (sha256
+        (base32
+         "1hcfcxz5fjzl7606prlb7dgls5kr8z3wb51h48s6qm8ang0b9nla"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:tests? #f))  ;no "check" target
+    (home-page "http://www.roaringpenguin.com/products/remind/")
+    (synopsis "Sophisticated calendar and alarm program")
+    (description
+     "Remind allows you to remind yourself of upcoming events and appointments.
+Each reminder or alarm can consist of a message sent to standard output, or a
+program to be executed.  It also features: sophisticated date calculation,
+moon phases, sunrise/sunset, Hebrew calendar, alarms, PostScript output and
+proper handling of holidays.")
+    (license gpl2)))