summary refs log tree commit diff
path: root/gnu/packages/ccache.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2014-05-20 12:20:12 -0500
committerEric Bavier <bavier@member.fsf.org>2014-05-20 16:21:43 -0500
commit5bbd6bf1815398f3cbe3d2f218b537a82f7219a7 (patch)
tree45b7b787e982bf656f745cea8c003d7fd3397e51 /gnu/packages/ccache.scm
parent16ecf3ff4a06b35c2f74325606e915c782ef2549 (diff)
downloadguix-5bbd6bf1815398f3cbe3d2f218b537a82f7219a7.tar.gz
gnu: Add ccache.
* gnu/packages/ccache.scm: New file.
* gnu/packages/patches/ccache-stdc-predef-test.patch: New patch.
* gnu-system.am (GNU_SYSTEM_MODULES): Add ccache.scm.
  (dist_patch_DATA): Add patch.
Diffstat (limited to 'gnu/packages/ccache.scm')
-rw-r--r--gnu/packages/ccache.scm57
1 files changed, 57 insertions, 0 deletions
diff --git a/gnu/packages/ccache.scm b/gnu/packages/ccache.scm
new file mode 100644
index 0000000000..4918ec9609
--- /dev/null
+++ b/gnu/packages/ccache.scm
@@ -0,0 +1,57 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages ccache)
+  #:use-module (guix packages)
+  #:use-module ((guix licenses) #:select (gpl3+))
+  #:use-module (guix download)
+  #:use-module (guix build-system gnu)
+  #:use-module (gnu packages)
+  #:use-module (gnu packages perl)
+  #:use-module (gnu packages compression))
+
+(define-public ccache
+  (package
+    (name "ccache")
+    (version "3.1.9")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append "https://www.samba.org/ftp/ccache/ccache-"
+                          version ".tar.xz"))
+      (sha256
+       (base32
+        "1i06015jjc0n55xgvhv2h37fjp0i7z8a10s0v40f87c5mprzv0a9"))
+      (patches (list (search-patch "ccache-stdc-predef-test.patch")))))
+    (build-system gnu-build-system)
+    (native-inputs `(("perl" ,perl)))   ;for test.sh
+    (inputs `(("zlib" ,zlib)))
+    (arguments
+     '(#:phases (alist-cons-before
+                 'check 'patch-test-shebangs
+                 (lambda _
+                   (substitute* '("test/test_hashutil.c" "test.sh")
+                     (("#!/bin/sh") (string-append "#!" (which "sh")))))
+                 %standard-phases)))
+    (home-page "https://ccache.samba.org/")
+    (synopsis "Compiler cache")
+    (description
+     "Ccache is a compiler cache.  It speeds up recompilation by caching
+previous compilations and detecting when the same compilation is being done
+again.  Supported languages are C, C++, Objective-C and Objective-C++.")
+    (license gpl3+)))