summary refs log tree commit diff
path: root/gnu/packages/ccache.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2016-09-22 23:43:20 -0500
committerEric Bavier <bavier@member.fsf.org>2016-09-22 23:43:20 -0500
commitbd368c71749f09af69f5f5688cf536f0e943b868 (patch)
tree461a4bc6b0dccf4afd0190c29c54cc0f118dd43f /gnu/packages/ccache.scm
parent1a0ae573c7f04c2c9d1adb10ddeb816628f41c22 (diff)
downloadguix-bd368c71749f09af69f5f5688cf536f0e943b868.tar.gz
gnu: ccache: Use modify-phases.
* gnu/packages/ccache.scm (ccache)[arguments]: Use modify-phases.
Diffstat (limited to 'gnu/packages/ccache.scm')
-rw-r--r--gnu/packages/ccache.scm15
1 files changed, 7 insertions, 8 deletions
diff --git a/gnu/packages/ccache.scm b/gnu/packages/ccache.scm
index 01db7ae57d..9b8c147e69 100644
--- a/gnu/packages/ccache.scm
+++ b/gnu/packages/ccache.scm
@@ -43,14 +43,13 @@
                      ("which" ,(@ (gnu packages base) which))))
     (inputs `(("zlib" ,zlib)))
     (arguments
-     '(#:phases (alist-cons-before
-                 'check 'setup-tests
-                 (lambda _
-                   (substitute* '("test/test_hashutil.c" "test.sh")
-                     (("#!/bin/sh") (string-append "#!" (which "sh")))
-                     (("which") (which "which")))
-                   #t)
-                 %standard-phases)))
+     '(#:phases (modify-phases %standard-phases
+                 (add-before 'check 'setup-tests
+                   (lambda _
+                     (substitute* '("test/test_hashutil.c" "test.sh")
+                       (("#!/bin/sh") (string-append "#!" (which "sh")))
+                       (("which") (which "which")))
+                     #t)))))
     (home-page "https://ccache.samba.org/")
     (synopsis "Compiler cache")
     (description